Showing results for 
Search instead for 
Did you mean: 

TUF x570-Plus No Internet Option / Bios Update not working

Level 7

i've got a TUF Gaming x570-Plus (wi-fi) running Bios Version 2407.

With the 2603 Bios released two days ago i've wanted to update my bios, i wasn't able to using:

1. AI Suit 3 -> Ez Update -> Error message "bios not matching current bios rom", when trying to manual update.
The automatic version in ez update has not been finding any new version and frankly has never worked for me before.

2. in BIOS:
a) i cannot update from C:\, D:\ or a flash usb drive, it is telling me that the "...2603.cap" would not be a proper bios file.
b) all of a sudden i don't have the option to flash over the internet any more, the option is just gone.

My Questions:

I. what is AI Suite good for anyways? the software seems outdated to me.
II. Armoury crate -> latest from website and beta in MS Store don't let me update bios from within the software. why is there no option?
III. What the heck is ez update good for? it has never worked before
IV. can somebody help me fix the missing internet option in BIOS? i would like to give it a shot at updating my bios. it would be greatly appreciated.

Dear Asus, your hardware has always been fine, but what on earth is up with your software department? sort the bugs, drop a few software distributions and focus on ONE working suite. its a desaster.

Level 7
I have exactly the same issue , i just perform my bios update from the bios ez flash 3 utility i'm stuck with the 2603 bios : and now i miss the internet option in the ez flash 3 update bios mode

You provided an updated bios ver 2603 that i installed by using the safest way : bios advanced option ez update flash 3 on a asus tuf x570 gaming wifi . Now my ez update flash 3 doesn't work anymore : no internet option , no usb option in the bios i'm stuck in the ssd drive directory in the bios and i can't roll back to a bios downgrade . i'm stuck with the 2603 bio who does not work well.. my cpu is running slower on overclock .. even ez update on ai suite 3 doesn't work anymore..And it appears that you have now deleted from your website the 2603 bios ver... What are you going to do ? i need help on this and i'm not alone other guys have the same issue :mad:

Level 7
SAME problem here. Have been trying to get this board to work for a month already.


I also have the same board, X570 TUF Plus WiFi and was using 2407 BIOS, today I updated to the latest BIOS update:

Version 2607
2020/08/1718.83 MBytes
"Improve system performance and stability
Improve Fan control function
Improve DRAM stability
Update AM4 AGESA combo V2 PI
Improve system stability
Improve DRAM performance"

It worked fine for my motherboard. I also noticed that the option to update the BIOS via Internet is not an option. I have a USB with the .CAP file in it and when I clicked the BIOS utility tool in my BIOS, It went direct to the path where the 2607 .CAP file and I have successfully flashed to the new BIOS

Level 7
I put in the 2607 and it seems OK.
I hope you guys are OK with it also.

nevermind... it was my fault.
i did choose the wrong board:
TUF GAMING X570-PLUS while im using the TUF GAMING X570-PLUS (WI-FI)

did choose the correct bios version, was able to update through a usb drive in bios and am now running 2607.

still, the ez update INTERNET option is still not available in bios 2607.

I just uptaded to the 2607 using the flash by my nvme directory :

Same issue the choice to update the bios by usb or internet is gone..

My cpu is running at 4 (2607 bios) instead of 4.1 G previously (1407 bios)

The 2 good news are : 1. it seem's that the blue screen crash issues were due to the 2603 version.
2.My system was horribly slow and it seem's that it was also due to the 2603 bios.

received an update to an incident with the asus support team today, and learned, that the missing internet option is know and in fact was removed due to too many RMAs with broken boards after failed bios updates' via internet - i was told to use the usb option, you can choose the drive from the listed available partitions.

so that's that.

Updated to 2607 from 1407 on TuF Gaming-plus x570. Computer constantly crashes while trying to load post. Had to clear cmos and found the 3600Mhz memory cant go past 3400 Mhz with out crashing. Bios is not only happy until memory frequency is set below 3400Mhz and the DOCP profile won't work. Found CPU temps are up also on my 3900X and cores jump around more.