Showing results for 
Search instead for 
Did you mean: 

Troubleshooting old Crosshair V formula series of red led's no boot.

Level 7
Hello, i have done a few searches and have not come to my exact problem so i would like any additional assistance before i write off this motherboard. I know it is old. I know it might be dead. But i am looking for thoughtful help to do any additional troubleshooting without having spare gpu, mobo, and cpu parts to swap out if possible and possibly anybody who has had similar situation may see this as this is still a very powerful pc that likely outperforms an average household pc although in rog terms it is a few generations old, may not run the latest edition of battlefield at optimal levels and doesn't have a dedicated subforum.

Computer shut down while running dual monitor gaming and 2 videos browser and investment app open during which temperatures were being monitored through ASUS software and no abnormal temperatures were detected on MOBO or CPU. On initial restart. No boot, black screen, motherboard indicated CPU issue through red light. Cleaned Power supply and MOBO with vacuum/duster. Spot cleaned with CRC electronics cleaner and lint free cloth.
Removed power cable shut off psu. Removed battery from bios changed battery for new one. Tested PSU with cheap PS tester. Proper voltages. Same results 24 hours.
Jumped CRTC SWITCH on MOBO to clear bios as in manual with power off and disconnected and no clock battery. Left for 12 hours. Removed DRAM left out overnight on notebook while CRTC SWITCH jumped. Tried boot with 1, 2, and 4 different sticks of ram in appropriate slots. During these instances of starting the CPU light has now gone away and DRAM light has went red. Tried Go button to indicate memory was compatible dram light flashes red for a minute goes back to solid red.

Removed all peripherals including speakers and usb connections. Attempted to clear bios again. Let sit for another 24 hours. Swapped ram for 2 spare ram sticks almost equivalent but slightly lower grade DDR3 ram. Now dram light has not appeared instead a red light comes up for the VGA/GPU and Boot Drive at same time.

Removed GPU, and DRAM. Removed MOBO from case. Put all on cardboard box. Inspected MOBO. No visual bulges in capacitors or burn marks anywhere near.
Some dust around north bridge. Removing north bridge later to replace old thermal pads with ic diamond thermal paste later for first time. Did southbridge with kyronaut

Historically i have had temperature problems with my PSU, GPU, and CPU. All have been resolved previously through dust removal and reapplying thermal paste/pads and or waiting 24/48 hours. I do not recall ever getting a dram red light. When i could not figure out what the problem was it was usually the PSU overheating. Last summer i was unable to put PC under load without shutdown until i reapplied thermal pads to VRMs inside GPU. Was restricted to browsing and video playback until fix.

Any advice to further diagnose in no boot situation?
Any software to recommend to test reliability of MOBO if/when does boot?
Methods of monitoring north and south bridge temperatures?
How to stress test psu for reliability without damaging pc?

Just bought new Seasonic 850w gx prime. Still red vga and boot drive light. Switched to ancient VGA without additional pcie power (not sure it still works or compatible)same thing.

Should i try to flash my bios? I am running out of options before buying new expensive stuff.

System specs built in 2011
MOBO - ASUS rog crosshair v formula
Processor - AMD phenom 1100t w/ cool master evo 212 1 fan installed in last 3 months
GPU - XFX 6970 HD radeon
PSU - XFX 750 watt 80 plus gold non modular
DRAM - GSKILL ripjaws ddr3 1866pc3-14900 81992mb cl9 10-9-28 1.5v x 4
swapped with spare GSKILL SNIPER ddr3 1866 pc3 14900 4096mb 10-9-28 1.5v x 2
Boot Drive - SSD samsung EVO 860 1 TB installed last 3 months
2 Hard Drives
Case - Antec DF-85 5 fans total/2 back fans 4 pins hooked directly to mobo

Summary. PC shutdown, CPU red light, reset CPU thermal paste waited. DRAM red light, more trouble shooting, VGA and Boot drive red light. Thank you for any feedback?