Showing results for 
Search instead for 
Did you mean: 

Think new Mobo is faulty

Level 10
New MAXIMUS VI EXTREME (C Stepping) and Intel 4770K, no matter what I do there is 1 of the 4 MEMOK LED's lit permanently (not flashing).

It is the 3rd one so assume its either for slot 2 or 3 depending on what way its wired but even with 1 stick of Memory in any slot it still stays lit.

I started with 1 stick nearest the CPU and it still lit.

I have tried all 4 Corsair sticks in all slots, same again with 4 GSKILL sticks and the same LED lit.

I have tried every bios and powered down and reset bios each time with battery removed.

I took Mobo out of case, removed the Noctua cooler and CPU and checked all pins were fine and then fitted the Intel cooler to make sure no bending of PCB was cause of issue.

I ran it on a bit of cardboard so no shorting going on.

I have no other PSU to try but the Enermax Revolution 85+1020w which was fine in my Rog Z68+2700k+16GB.

The PC boots and I had Windows up and running but if I try to change from Auto to CPU Level Up 4.2 or above it simply will not post or gets as far as Windows boot screen then gets a BSOD.

Once it did get into Windows at 4.2 but crashes almost instantly upon stressing.

I also tried to load the Gamers profile, same again no post or BSOD.

I tried some manual settings but am coming from Z68 to Z87 so need time to learn the new settings but those auto overclocks should work or at least post/get into OS.

I think this Mobo is to blame as its very rarely the CPU as it works or does not and there is no fault code or warning lights at the 24pin socket but that MEMOK LED should not be lit.

All above was tried with both my memory kits and 1-4 sticks and always same end result of no post or a BSOD.

It also tends to forget some changes to the bios I make but my Z68 did the same early on till later bios builds.

I know it happens as my Z68 was DOA with no codes but 1 red LED and replacement worked fine.

Level 10