cancel
Showing results for 
Search instead for 
Did you mean: 

Think new Mobo is faulty

jh30uk
Level 10
New MAXIMUS VI EXTREME (C Stepping) and Intel 4770K, no matter what I do there is 1 of the 4 MEMOK LED's lit permanently (not flashing).

It is the 3rd one so assume its either for slot 2 or 3 depending on what way its wired but even with 1 stick of Memory in any slot it still stays lit.

I started with 1 stick nearest the CPU and it still lit.

I have tried all 4 Corsair sticks in all slots, same again with 4 GSKILL sticks and the same LED lit.

I have tried every bios and powered down and reset bios each time with battery removed.

I took Mobo out of case, removed the Noctua cooler and CPU and checked all pins were fine and then fitted the Intel cooler to make sure no bending of PCB was cause of issue.

I ran it on a bit of cardboard so no shorting going on.

I have no other PSU to try but the Enermax Revolution 85+1020w which was fine in my Rog Z68+2700k+16GB.

The PC boots and I had Windows up and running but if I try to change from Auto to CPU Level Up 4.2 or above it simply will not post or gets as far as Windows boot screen then gets a BSOD.

Once it did get into Windows at 4.2 but crashes almost instantly upon stressing.

I also tried to load the Gamers profile, same again no post or BSOD.

I tried some manual settings but am coming from Z68 to Z87 so need time to learn the new settings but those auto overclocks should work or at least post/get into OS.

I think this Mobo is to blame as its very rarely the CPU as it works or does not and there is no fault code or warning lights at the 24pin socket but that MEMOK LED should not be lit.

All above was tried with both my memory kits and 1-4 sticks and always same end result of no post or a BSOD.

It also tends to forget some changes to the bios I make but my Z68 did the same early on till later bios builds.

I know it happens as my Z68 was DOA with no codes but 1 red LED and replacement worked fine.
20,284 Views
20 REPLIES 20

Retired
Not applicable
hello, which are the ram kits you are using?

Retired
Not applicable
was it the vengeance that made it possible to boot win?

jh30uk
Level 10
Corsair Vengeance Pro Series DDR3 1866MHz 4GBx4 ( CMY8GX3M2A1866C9R ) and GSKILL RipJaw X DDR3 1600 4GBx4 (F3-12800CL7D), both work fine in my Z68.

I know the Corsair is on the supported list, not checked for the GSKILL as that is my old Ram now.

I do not think that LED should be lit even with slot empty added to other issues.

Retired
Not applicable
the reason why i asked, there are modules out there that can be tricky with the boards

Retired
Not applicable
the g.skills is less chance to run well i think, depending on if its Elpdia or PSC inside.. and if its Elpida inside, i know people having issues getting them running at only 1866mhz stable

The Vengeance shouldn't be any problems..

The problems can occur, if different ram are being swapped back and forth, without clearing the cmos in between the swaps, among other things..

so if you started off with the ripjaws and got an error (which i can understand if its PSC IC's in yours), and then swapped to the Vengeance.

clear cmos
install one vengeance stick, in anyone of the red slots
power on
press F5, followed by F10 (save and exit) in bios, reboot

What happens

jh30uk
Level 10
I can boot to Windows and use PC normally with any of the kits even all 16GB but that LED remains lit.

I built it using the Corsairs (a few weeks old) and were in my Z68 at end up.

I only used the GSKILLS to eliminate the Corsairs.

I cannot OC in any way so far and have not stressed it even at stock as 2 days now wasting my time messing about.

I reset bios fully each time, even went overboard and took out battery (same not so easy to get place behind GPU as Z68 Rog) and left power of for 10mins after discharging by pressing buttons.

I am on PC now typing here and playing music.

Retired
Not applicable
ok, so all the ram modules are recognized in bios? and with the right amount of GB? 16

I think you should focus on getting the Vengeance to work, its to play it safe.. many of the older ram modules out there, is tricky sometimes..

Today is often Hynix or Samsung in the sticks, and they cause almost no issues when used on the boards of today

hope someone else can help you this evening, need to sleep soon..

Good luck

jh30uk
Level 10
Me too, eyes and hands are sore with messing inside PC case all day (swapped cases to).

All Ram is seen in bios and Windows.

There is nothing I can do to fix this issue I think Mobo has to be swapped but was wondering if anyone seen this before.

HiVizMan
Level 40
Please confirm you ran Memtest86+ as per my guide. And that all the steps were carried out.
To help us help you - please provide as much information about your system and the problem as possible.