cancel
Showing results for 
Search instead for 
Did you mean: 

Stuck on Bios Splash Screen

betaman10
Level 9
This morning when I turned on my computer it proceeded to boot and after my 2 raid contollers booted it just sat there on the bios splash screen. I couldn't get into the bios and Windows wouldn't boot. I tried a bunch of things like remove video card and try another one and same thing. I then switch to bios 2 and that seems to have fixed this. I am afraid to go back to bios 1 because I have no idea what happened and don't want it broken again. Has anyone seen this?

Thank you,
Dan
11,133 Views
4 REPLIES 4

HiVizMan
Level 40
It happens - could be a whole heap of reasons. Ram, CPU even your storage controller. I would not worry to much, a simple clear CMOS will fix most things.

Out of interest what was the LED code stuck on?
To help us help you - please provide as much information about your system and the problem as possible.

I did clear the bios a bunch of times nothing fixed it. Switching to bios 2 did though. It was stuck on code 62.

8_Pack
Level 12
62 is usually a RAM related problem I have found. Which Bios???

Bios 1 is 1005 and bios 2 is 1101. Bios 2 is working fine.