Showing results for 
Search instead for 
Did you mean: 

Struggling to get 1TB NVMe working in my Asus B450M-A

Level 7

So i purchased this: Fanxiang S660 1TB PCIe 4.0 NVMe SSD M.2 2280 internal SSD with heatsink.

I downloaded Macrium Reflect and Balenaetcher software and cloned my existing SSD using each to see if either would work for me, but no.

I have made sure that SATA6G-5 and 6 ports are empty as per my understanding. I have 16GB of RAM.

Booting into the bios (version 3211) the NVMe is actually there and visible (incl boot drive). Upon startup with the first screen headed "asus in search of Incedible" with little circle at the lower part of the screen is spining around and then it freezes -see below.


Finally I also tried booting up a win10 usb and deleted all the partitions of the NVMe so only one partition remained of 931.5GB. I selected nect to install and got the message:
We couldn't install Windows in the locatonyou choose. Please check your media drive. Here's more info about what happenned: 0x80300024.

I even tried hiting the format option on that partition first and trying again - still no luck.

I am aware the drive purchased is PCIe 4.0 and the port on the MB supports 3.0, but i am thinking it should still work as it's backward compatable...or is it not? I did not put the heatsink on it as I wanted to get it working initially before I start sticking stuff on it because I might end up sending it back to Amazon.

Any help would be welcome.



Level 7

I also forgot to mention 2 things. After I had removed all the partitions via the usb windows boot installler and put back my old ssd and brought up the system I was able to see the NVMe drive when i plugged it as another drive - as an NTFS full emptry drive.

The other thing i had tried prior to removing and reformatting the drive I tried to restore a system image I had created on another drive. I got this error popup and not sure if it indicates that I need to make an additional chnage to some parameter in my BIOS..?



Level 7

I see my first picture i posted shwoing where the pc was hanging every time does not display - added again

IMG_20230921_192718 (1).jpg

Addtionally the NVMe drive is being put into an enclsure and plugged into my USB port when I cloned my system drive , not sure if this too is a factor for the failure of this process.

So, update. I sent back the drive and got a Crucial GEN3 one and i seem to get further.

In that if I try and boot from USB I am able to install windows and get it to bootup, but trying to clone my existing drive - in its entirity does not boot up. After more research I see I may need to intsall NVMe drivers first before cloning my system drive. And that is where I am stuck. Where do i get them from?