Showing results for 
Search instead for 
Did you mean: 

Strix X570-F 1403 BIOS problems

Level 7
Since updating to the new 1403 BIOS my PC will no longer post at 3600 RAM. I basically have to down clock to 3200 in order to post.

Anyone else having this issue?

Level 7
G.Skill 4266 only boots as 2133, before it was working as DDR3600 with 1800Bus/IF clock since the beginning - opened already another thread for this issue/board.
I even had to start from scratch with my settings, as all of my profiles set lots of values to nonsense (SATA, LAN, Audio, USB3 all to off, VRM switching frequency 15200, ProcOdt to high impedance ...) - all previous Bios version had no issue when loading one of these profiles.

I have the -E board and same problem!
Just add all Ram settings manually and it should boot! With this bios the boards don't read any more xmp

Same here. As I found out, this is a problem that affects not only Asus but also Gigabytes and MSI.

Furthermore, sound cards in the pci-e slot cause problems

I`ve got both.

Now it's turning on with fans running, but it isn't showing Bios screen anymore and the TUF X570 has no CMOS clear button and it is hard to access the jumper in my setup ...
That's the biggest b.....t I've ever had since I own PCs, and with 50+ this is a long time!


same here - X570 Strix-E

My TUF X570 had previous infinity clock of 1866 but with this new bios update it gave black screen with it so I had to lower it to 1800 to get my system boot to Windows

With my setup I tried to set all the values manually for 3600/1800 and it still didn't work. What I did find kinda work was to set everything for 3200 and then set it to 3600. However after a cold boot it would also fail.

I might try again, but in the meantime I used the flashback button to go back to a previous bios.

Same exact issue with strix-f x570. Ram has to be downclocked to 3200 from 3600, only thing that will allow post. Clear cmos is the only option if i change anything

So I got my TUF working again after CMOS Reset ...

Used Overclocking Auto instead DOCP (not sure why Auto allows settings of Frequency but anyway - CPU-Z showed correct values) and setting DDR 3600 with FCLK 1800Mhz, 15/15/15/15. Voltage at 1.35V, IF 1800MHz ... and it worked for the last 2 hours, playing games only.

*The only thing is that secondary and third timings are far to high, but for now it's ok and I hope they get the XMP Profile working again, so that I get the better timings automatically.*