Showing results for 
Search instead for 
Did you mean: 

Strix X470-F BIOS v.5216 Pop!_OS bug

Level 7
So I updated my BIOS recently, because I was thinking about buying a Zen2 cpu, the thing is my popos installation started acting weird.
To be more precise I get no output from my gpu seemingly at random and the signal might return or it might not.
After reading the 5216 description again I noticed that it said it was supposed to fix some Linux compatibility issues and I can confirm that other distros I tried, Arch, Manjaro, Debian, even Ubuntu, worked just fine... apart from popos.

So I'm new here I don't know if this is the right place for me to post this. Here seemed appropriate if not please give me a link for were I should post/report this bug.

Level 7
After a few days of tinkering I noticed something that might be useful.
So I have my monitor plugged in to my graphics card via DisplayPort and with this config the previously mentioned behavior is observed. Now when I connect via HDMI everything works just fine! No signal issues whatsoever.
I will buy an HDMI cable, but if this is actually a bios issue and not say my graphics card's or my monitor's issue (which I highly doubt) it should be examined by asus' bios devs. Even for me changing cable for my input is a temporary work around since I'm planning on buying a secondary monitor in which case I'll need to use one of my gpu's DP and I'll back to the same (probably).