Showing results for 
Search instead for 
Did you mean: 

Strix b660-a d4 Xmp ram issue

Level 7

I am having a weird issue where I cannot boot my pc when i set my ram to its intended 3600 speed xmp profile. I have tried 3 different sets of Ram. A set of a g skill and a set of Corsair ram. But they both can’t seem to use xmp. It is a set of 2x8 sticks. It works if i use only one stick with the xmp. Even if i manual adjust the frequency it still doesn’t work. If i want to run 2 sticks then i have to run at default bios setting which sets the ram to 2000mhz which is much lower.

The only set that works when using 2 sticks is the ddr4 3200 set i have.

Does anyone know what is causing this? I'm starting to think this board doesnt support xmp higher than 3200. Anyone else with this board with ram running faster than 3200?

My cpu is I5 12500f. And motherboard is Strix b660-a d4 wifi

The3 ram sets that don't work:
-‎ CMW16GX4M2C3600C18 version 3.32
- F4-3600C16D-16GVKC
- TDZAD416G3600HC18JDC01 (this was from my cousins strix b550-f wifi system)

Super Moderator

Please read the following thread:

Anything over 3200 on that platform is considered an overclock. If you're struggling with all ratios above this you may want to look at tuning the System Agent voltage first.
13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090