cancel
Showing results for 
Search instead for 
Did you mean: 

Strix B350-F detects both ram sticks, but can only use one.

Aaaaaaaaaaaaagh
Level 7
Hey all,

I just finished a new build for my PC! However, I'm having issues with actually getting both of my sticks of ram to work. I picked up 16GB of DDR4 3200mhz RAM, but my BIOS only shows my memory as 8192 MB, indicating that only one stick is working. However, going into the settings in the BIOS reveals that both sticks are detected (and are currently running at a base of 2133 mhz).

I'm running a GTX 1070 Armor OC and a Ryzen 7 1700, but I don't think either of those have to do with the issue at hand.

My RAM model is the G.Skill TridentZ 3200CL14 with timings of CL14-14-14-34. My model number for my ram is F4-3200OC14D-16GTZ.

My task manager shows that I have 8.1 GB of RAM reserved for my system, which makes absolutely no sense at all.

My settings show that I have 16 GB installed, but only 7.94 GB usable. Is there ANYTHING I can do to fix the issue? I think it's an issue specifically with my BIOS but I have no idea what it is or how to fix it. 😞

Thanks and cheers. I'll donate some BTC to whoever can actually solve this. Can't find anything online and this issue is stressing me out to the max.
4,706 Views
3 REPLIES 3

mariuscc
Level 7
I'd say one of the sicks has an issue. Try them separately. See which one is dead then RMA.

Alternatively try (each one and/or both) in a different system.
He who invokes history is always secure.
The dead will not rise to witness against him.

You can accuse them of any deeds you like.
Their reply will always be silence.

hi there, i had the same issues with my flarex - F4-3200C14D-16GFX. first i installed them into a1/b1, just to find out that asus likes them in slot A2/B2. so i swapped them around then put them into A2/B2 and after 2 resstarts it was ok and the bios and win10 found them both.
Orwell was an optimist