Showing results for 
Search instead for 
Did you mean: 

[SOLVED] VI HERO - Asmedia not working

Level 10

So, it seems I am not that lucky and I finally stumbled upon a problem with my dear VI Hero.

I am using all 6 Intel SATA ports with:
1 x Samsung Evo SSD 126 GB 6 Gb/s
1 X Seagate 2 TB 6 Gb/s
4 x WD 2 TB 3 Gb/s

This leave me with the 2 Asmedia ports free for a DVD and some mobile SATA device I can connect through my external E-SATA on my Case.

Nevertheless, It seems my 2 Asmedia SATA ports do not wish to play nice.
DVD-RW was not even visible and plugging an additional SATA drive on the 8th port made my whole system unstable.
Could not even format, delete partitions, create partitions or for that matter anything while connected to the 7 and 8 SATA ports.

I thought because I had too many devices populating all SATA ports, so I unplugged the 4 X WD.
Same problem.

I then moved my external SATA disk and DVD-RW to SATA 4 and 5 on Intel controller.
Both devices started to work normally.

Asmedia SATA is enabled in BIOS.
SATA cables are OK, seeing as with the same cables the devices work on the Intel controller.

I am out of ideas.
Please throw some at me.

Level 10
Problem fixed by updating to BIOS version 1402 and clearing CMOS.
Either just clearing CMOS or the new BIOS version, I am not sure, fixed it.
I did not clear CMOS before to see if it would fix my problem.

Thank you all for your input 🙂