cancel
Showing results for 
Search instead for 
Did you mean: 

Sabertooth Z77 Bios kaput Flashback not working.

guily6669
Level 7
Hi there,

I spent a whole day trying to make Sabertooth Z77 flashback to work and it doesn't.

I have done exactly like instructions:

1- USB Pen Drive to both Fat and Fat32 as MBR and many different allocations sizes + many USB pen drives including mSD and SD with a USB reader...;

2- Downloaded many Sabertooth bios versions, extracted the bios file and renamed to Z77ST (CAP file) and put it on the root of the usb drive;

3- Then I put the USB pen in the Flashback USB3.0 port and press the Flasback button until it starts to blink but then it always turn solid blue after like 3 or more blinks (and only with low allocations sizes it blinks a few extra times but then solid blue after a few seconds).


Anyway the PC was working fine but I flashed ME with "AFUWINx64" using either "/MEUL" or "/ME" can't remember which and my PC doesn't POST anymore and the flashback not working is most likely not related because even when the PC was fully working before the Flashback never worked 4 me...

AFUWIN INFO:

- /MEUL: Program ME Entire Firmware Block, which supports Production.BIN and PreProduction.BIN files.
- /ME Program ME Entire Firmware Block.


ps: Really need help!!!!!!!!!!!!
936 Views
2 REPLIES 2

Nate152
Moderator

guily6669
Level 7
Sadly no, I followed them properly... I also mailed ASUS, but I only got a reply saying to do CLRTC by using the jumpers, but sadly I had already previously done that and even removed the battery and they haven't replied anything new yet 😞

The only time it really almost looks like it's working it's with a super old 256MB USB Pen drive that I have here, but I guess is mostly only to do with the fact that the pen drive is SUPER SLOW, but the motherboard clearly reads it because 2 USB pen drives I tested have activity LED and they light up after the Flashback blinks 3 times but sadly it always turn solid blue after...

ps: For now I tried hot swapping the bios chip on my Sabertooth P67, but I don't know what to do since "AFUWINx64" only reads 4MB (which is the size of the P67 BIOS) and doesn't flash anything. I have just bought a BIOS programmer today, will have to wait 4 it to arrive and see if anyone could help me in other forum (some people are trying to help me on win-raid... forum). HOWEVER IF ANYONE KNOWS ANYTHING NEW I CAN TRY WITH THE BIOS FLASHBACK FUNCTION PLEASE POST!!!!

EDIT: FIXED WITH THE USB PROGRAMMER, (mods can close this thread)