cancel
Showing results for 
Search instead for 
Did you mean: 

Rog logo in my B450-F doesn't light up

andresca6
Level 7
Hi, i need some help with this, the rog logo on my B450-F doesn't light up. Not even the aura sync software recognyze my mobo. I've seen some videos iin wich people say "You need to dissable the led light in the bios, or re install the aura sync software", and i did, but still it doesn't work. I flashed the bios and the problem persist.
4,276 Views
3 REPLIES 3

Stiglitz26
Level 7
I have the same mobo and also the same problem.

At 1st the ROG stayed stagnant in green. Aura Sync not working for the board when i tried to change setting. Then I shut down and guess what....the ROG logo doesnt light up. Been trying almost whatever advices i can get over the internet but problem remains. Is my mobo spoilt? Its only 2 days old.

Prior this, the ROG logo will power off 10 seconds after logging in to window. Need to open Aura Sync or Amoury Crate to switch it on again. Then without doing anything it simply just solved the issue without doing anything. Then only just an hour ago...the problem above happened. Now the ROG logo totally dead! Pls tell me its just merely software and not hardware issue. I hate going tru RMA during this Covid-19 as my country low on stocks and dont think I can get a one on one exchange.

Pls help!!!

Managed to restore the ROG logo by reinstalling Aura Sync but still cant change the color. Will reformat my windows solve this?

Shut down desktop and powered on 2hrs later.........back to the same. ROG logo not lighted up. Will reformating settle it?