cancel
Showing results for 
Search instead for 
Did you mean: 

RIVE Win7 startup hang

bravegag
Level 7
Hi,

I have been getting this Windows 7 hanging for 2 minutes every time I start up and decided to investigate. Checking the Windows 7 Event Viewer reveals the issue:

"Error. Service Control Management. 7022.
The AsusFanControlService service hung on starting."

This is part of the Asus AI Suite II I believe. How can I fix this?

Many TIA,
Best regards,
Giovanni
ASUS Pro WS X299 SAGE II
Intel i9-10980xe 18C
Corsair h150i ELITE LCD
Corsair Dominator CMT128GX4M4D3600C18 128GB 4x32GB
ASUS ROG STRIX RTX 3090 O24G
Adaptec RAID 8805 (2x SSD RAID0 - Windows 11 Pro, 2x SSD RAID0 - Ubuntu, 4x Seagate IronWolf RAID10)
Corsair AX1600i PSU
Corsair Obsidian 750D
134 Views
7 REPLIES 7

luzhanyi
Level 7
I faced the same problem, it seems to happen on both win7 and win8
just go to services and disable "AsusFanControlService" it could be fine
CPU: 4790K
MB: Maximus VII Hero
CPU Cooler: Noctua D15
RAM: Kingston 8Gx2 2400 10-13-13-24-CR1 @1.65v
Graphics: Inno3d GTX 1070
Storage: Intel SSD 750 400G/Corsair Neutron 240G/Corsair Neutron XTi 480G/2T HDD x3
PSU: SilverStone Strider Gold 1200W
Case: Phantek 515
Monitor: Dell 2913wm
Keyboard & Mouse: Corsair K70 RGB Rapidfire & Logitech G502

bravegag
Level 7
Thank you! did it now 🙂
ASUS Pro WS X299 SAGE II
Intel i9-10980xe 18C
Corsair h150i ELITE LCD
Corsair Dominator CMT128GX4M4D3600C18 128GB 4x32GB
ASUS ROG STRIX RTX 3090 O24G
Adaptec RAID 8805 (2x SSD RAID0 - Windows 11 Pro, 2x SSD RAID0 - Ubuntu, 4x Seagate IronWolf RAID10)
Corsair AX1600i PSU
Corsair Obsidian 750D

HiVizMan
Level 40
How did it pan out bravegag?
To help us help you - please provide as much information about your system and the problem as possible.

Blixt
Level 7
I had the same problem when i got the RIVE, and it indeed turned out to be "AsusFanControlService" 😛
Asus Rampage IV Extreme (Bios 3301)
i7-3820 @ 4.7GHZ 1.38V
XSPC RayStorm 750 RS360 Push/Pull
Kingston DDR3 HyperX 1600MHz 32GB @ 1666
3x HD 7970 VAPOR-X GHz Edition @ 1250/1750
2x Intel SSD 520 Series 120GB Raid0 & 2x WD Caviar Black 1TB Raid0
1x WD Caviar Black 1TB
Windows Ultimate 7 64 bit
Cooler Master Pro M1000W
Dell UltraSharp U2711 "27" 2560x1440
Cooler Master HAF X

GoogalyMoogaly
Level 7
Is that service not needed if you want to control the fans speeds though?
Do we know the last version of AI Suite that didn't have this issue?

Asking as I think I may be getting the same issue. Want to run the service though as I have a custom CPU fan profile.

HiVizMan wrote:
How did it pan out bravegag?


Thanks for asking HiVizMan worked perfectly after disabling the AsusFanControlService.

GoogalyMoogaly wrote:
Is that service not needed if you want to control the fans speeds though?
Do we know the last version of AI Suite that didn't have this issue?

Asking as I think I may be getting the same issue. Want to run the service though as I have a custom CPU fan profile.


The version is AI Suite II 2.00.01 latest one available for download I believe.
ASUS Pro WS X299 SAGE II
Intel i9-10980xe 18C
Corsair h150i ELITE LCD
Corsair Dominator CMT128GX4M4D3600C18 128GB 4x32GB
ASUS ROG STRIX RTX 3090 O24G
Adaptec RAID 8805 (2x SSD RAID0 - Windows 11 Pro, 2x SSD RAID0 - Ubuntu, 4x Seagate IronWolf RAID10)
Corsair AX1600i PSU
Corsair Obsidian 750D

scotland21
Level 9
The fans work fine with this service disabled,
G.Skill 16GB (4x 4GB) Quad Channel Ripjaws Z Series Memory Kit PC3-19200 CL10-12-12-31
CM Storm Stryker \ Rampage IV Formula BF3 edition \ SickleFlow 120 Green LED \ WIN7 PRO X64
SanDisk SDSSDX-120G-G25 SATA III \ OCZ Solid 3 120GB SATA III SSD \ RAID0
Mushkin Chronos 60GB SATA III SSD \ OCZ Agility 3 60GB SATA III SSD \ 2 x EVGA 660TI 2048MB SLI