Showing results for 
Search instead for 
Did you mean: 

Rampage V Extreme & DHCP

Level 8

I'm currently in the process of housecleaning my home network by having my Router assign IP Addresses to all my devices.

The basic idea was like that: Router 1st Wired Device 2nd Wired Device 3rd Wired Device
. Wireless Access Point 1st Wireless Device 2nd Wireless Device 3rd Wireless Device
. NAS ( FreeNAS ) NAS Remote Console 1st NAS Plugin 2nd NAS Plugin

Everything is working fine Except for the 1st Wired Device, my Main PC, with a Rampage V Extreme Mainboard installed.

The second I assign the desired IP Address ( ) to it's MAC Address on the router I loose connection to the whole network.
Windows 10 will offer me to solve the problem remarking that DHCP has not been activated on the Motherboards Intel Network Interface.
Trying to solve it by activating it results in a failure - Also manually setting the IP / Subnet / Gateway settings will also result in loss of connectivity.

I tried it with the most recent LAN Drivers provided on the ASUS Website and the ones from Intel themselves but no can do.
All I can do is to NOT bind it's MAC address to any IP and let it choose it's own which usually ends in something like

Am I missing something?

Level 14
What model (Thomson) network router? Is it running the latest-and-greatest firmware? And are you setting IP addresses/protocols through the router itself or through Windows?

I suspect the problem might be the (limited) options provided by the ASUS 3T3R WiFi driver - it should allow Windows to fully control and configure it, but (as we all know) Windows can sometimes be problematic over the most basic things, lol. You can try a generic AC1900/BCM94360 firmware and drivers, if any are available (for Win10).

I wasn't impressed by this built-in ASUS WiFi accessory, it had poor signal and too many connectivity issues. I ended up installing an AC1900 adapter card which I found works very perfectly (with consistently strong signal/bandwidth) in Win7, Win10, and linux.
"All opinions are not equal. Some are a very great deal more robust, sophisticated and well supported in logic and argument than others." - Douglas Adams


Level 8
Apparently I managed to get it working but how I don't know as I don't believe I did anything different - Maybe another order.

I, again, tried to manually set the IP Address on the PC itself and it again didn't work demanding a fix to the DHCP which I let it do.
I then went into the Router to, again, bind it's IP Address to the MAC Address and after a restart of the PC it worked.

Annoying AF but hey... Beggars can't be choosers.

Thanks for the attempt though! :°

Level 13
Id actually like a little insight into this schemes protocol over dynamic IP assignment and a strong encryption.
Forcing mac filtering stops anything else from connecting but at the same time offers up a piece to the puzzle that static IP resolves.
Just curious as why this choice.

“Two things are infinite: the universe and human stupidity, I'm not sure about the former” ~ Albert Einstein

Level 8
Mainly because of the FreeNAS Server which requires to have some of it's IP locked to specific ones.
Once I started locking it's IP's one thing led to another and I started the idea of locking EVERYTHING.