cancel
Showing results for 
Search instead for 
Did you mean: 

RAMPAGE IV reading over voltages!!! and get past bios!!! pls help

TehMaDDaNgLeR
Level 7
i7-4820k CPU
Rampage IV Extreme MOBO
32GB g.skill trident x 2400mhz RAM
290x single GPU
Corsair AX 1200
GPU and CPU are liquid cooled with XSPC kit.. currently all overclocks are off due to problems


I custom built this PC back in January. It's been running great for 6 months up until 3 days ago. Just moved into a new house set up the PC in the basement. I had the PC idling for a day or two before i got to finally game. After 3-4 hours of playing D3 it crashed on me so i booted back up only to cash within minutes then within seconds up until it wouldn't boot windows at all. After playing with the power (unplugging and what not) i finally got it to reboot only to be told "Power supply surges detected during the previous....." "Asus anti-surge war triggered...."and "CPU over voltage error!". So next i went into the bios to find out anything i could. Under the monitoring tab i found my CPU voltage is at 1.660v and in red, the 3.3v is reading at 3.008v, the 5v is reading at 10.08, and the 12v is at 21.120v. (all other voltages appear normal). My next step was to test the PSU with a multimeter and all voltages were within 3 % of their tolerances. I'm clueless as to what i need to troubleshoot next. I've already pulled the CPU off and inspected and reseated it. I've tested each ram stick individually and all are fine. If someone could help me out it would be great as ive been reading every forum i can find with similar problems but i still havent resolved my problem. Ive also flashed 3 different bios', none helping my situation.
594 Views
37 REPLIES 37

kawasakizx10rr
Level 8
RMA it imo . the board seems to be faulty . HiVizMan can help you with it . when he comes back to check on this thread. as it's only 6 months old.

TehMaDDaNgLeR
Level 7
Ya. I was afraid it might come to that. I'm taking it to the tech at the local shop tomorrow. Let him toy around with it for a few days and see if he has more luck than I. I'm fairly new to all these features so perhaps he can do something I can't. And again if just like to say I greatly appreciate all the help on here so far.

TehMaDDaNgLeR
Level 7
new discovery..... i have almost 40 "base system devices" that the drivers are recognized for... could all my problems be some sort of virus by any chance thats disabling monitors and screwing with sensors? Im going to try reinstalling windows i guess ... idk anymore
38488

TehMaDDaNgLeR
Level 7
just an update... took my tower into the shop finally. PSU passed 100%. tried a different CPU in it but it wouldn't boot or show anything on a monitor. Ran tests on my CPU and it passed 100%. Also tested the Ram it passed 100%. Only thing left i figure is something went on the MOBO. I got the tower home and im running it. 4.5 ghz @ 1.832V allegedly. Not to sure whats next now :'(

kawasakizx10rr
Level 8
Make a post titled "need help with rma"

imo that should get some attention

HiVizMan
Level 40
RMA the board and get one that works as it should.
To help us help you - please provide as much information about your system and the problem as possible.

TehMaDDaNgLeR
Level 7
last question ... do i RMA to newegg.ca or to asus ... and do either offer the chance to upgrade to the black edition? i dont seen anymore Rampage iv extremes on newegg.ca that aren't refurbished and i really dont want someone elses used product when i paid over 500 for my mobo

HiVizMan
Level 40
It all depends on how old your board is I guess. Not even sure how long the retailer is responsible for the warranty in the US. There is a thread sticky in the Rampage section on North American RMA.
To help us help you - please provide as much information about your system and the problem as possible.