Showing results for 
Search instead for 
Did you mean: 

Rampage IV Extreme - puzzling problem I've not seen before, any advice?

Level 8

I'm not particularly optimistic of getting much traction on a 10 year old motherboard, but maybe I'll get lucky! It's worth a shot anyway.

I recently inherited a dead Rampage IV Extreme with 32Gb memory and and 3960x CPU. The whole kit was filthy - it had been used in a dusty environment and looked like it had never been cleaned. The case and CPU fans would barely turn, and the motherboard was coated in a thick layer of dust and grime. A quick test showed that the power, reset and bios switch lights would light up, but it would not post and no fans were spinning. So I stripped the board down, took off the chipset heatsinks thoroughly cleaned all components off with a soft brush, applied some fresh Artic Silver thermal paste to the CPU area and the chipset and tried to boot with 1 memory stick.

No luck, still dead. I was not about to give up, and after a few weeks of internet research I stumbled across the hairdryer trick. It worked!! The motherboard sprang into life. I was so happy and excited to get the board running. Yes, it's old, but it's cool, and worthy to be preserved. It really was an amazing motherboard for its time.

So I build the board up in the case, populated with memory, graphics card, and an SSD, and booted up ready to install Windows 10. I entered the bios, and checked out a few things, and rebooted. I noticed by keyboard was not responding, so booted again and strangely the keyboard was not recognised at all. Tried a few other USB ports - nothing, Well, this is a Cougar 700k, and maybe it's a little temperamental with the Rampage IV, so i tried a few other USB keyboards with still no luck. Dug out an old PS2 keyboard and finally got it recognised. However, the board still had problems. None of the intel SATA ports were working. None of the rear USB worked, except for the 3.0 ports controlled by the Marvell chip. The CPU was running extremely hot (79°C at idle), and constantly throttling under the slightest load. One of the bios chips would result in a 00 post error. And the cold boot problem persisted, necessitating frequent use of the hairdryer, much to my wife's perplexion . Also, the clock was not keeping time. The initial elation of getting the board to boot slowly turned to sadness. Is the board savable? Is the CPU thermostat damaged? Maybe the clock generator is broken? I upgraded the one working bios chip from 1404 to 4901 using the CAP converter, and installed windows 10, hoping a new bios might solve some problems. No joy.

Since the CPU was constantly throttling, the PC was almost unusable and I did not feel comfortable running it so hot for long, so I stripped it back out of the case and back to a bare motherboard. First, the clock problem felt like a battery problem, and yes, the battery was not a CR3032 but something like a CR3025. Easily fixed. Next, the CPU cooler was checked out and it seemed the bottom face plate was loose and the two screws attaching it to the heat pipes were not tight. I examined the X7- chip with a magnifying glass and could see no damage. Neither were any pins on the CPU area bent or broken, all looked perfect under a magnifying glass.

So at the moment the good news is the CPU is now reporting decent temperatures. I've ordered a new BIOS chip which is due in a week or so. The cold boot problem persists but I can live with it for now. My main concern is the X79 chip. I noticed when I took of the heatsink to clean the mini fan and re-apply thermal past that it was wrapped in some type if tin foil that peeled off when I removed the heatsink. Did I somehow damage the chip? It's not running hot, and the fan is not kicking in unless I force it to in the bios.

Sorry for the rambling post. I am hoping that I can get some thoughts around:

1. None of the Intel SATA ports and USB ports are definitely a faulty X79 chip. Could it be anything else, corrupted BIOS or something I am missing?
2. Are there any other functions controlled by the X79 chip that I can test, indicating that the chip is not completely dead?
3. Did I damage it by removing the heatsink or foil? Does it need the foil or a thermal pad to function?
4. Is the board salvageable?

I guess, worse case, I could run the board using the Marvell SATA ports and 4 USB ports at the rear - hardly ideal though. A replacement Rampage IV is a route I could go down but the prices on eBay are astronomical at the moment, and I am not sure paying £300+ for a second-hand board that may be riddled with problems is a good move.

As you may have discovered in your research, one of the most common failures in older electronics is failed capacitors. So you could do a visual inspection to see if anything appears swollen or leaky. Unfortunately when you're talking about a motherboard these can be rather small and require special equipment to replace even if you can locate them.

Ultimately your best move could be to sell this board Parts Only on Ebay and use the proceeds to buy another socket-compatible board.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

Thanks, I did check the board with a magnifying glass and nothing obvious stands out.

I thought I'd update the thread just for closure. The Asus Rampage IV Extreme motherboard I inherited never really returned to full health. I was happy to get it partially working but it still had problems:

1. Cold starts often needed the hairdryer trick to get it to boot up,
2. The board would lose time, maybe 4-5 hours a day. No idea why.
3. None of the Intel internal SATA or USB ports worked.
4. None of the external Intel USB 2.0 worked.

I replaced a faulty BIOS chip, and plugged in a USB keyboard in a non-functioning USB port. The keyboard worked! However, I kept getting i-Rog 1and i-Rog 2 updates, after which the Intel USB stopped working again. Bummer. The internal SATA ports never sprang back into life, and only the Marvel headers functioned.

So I've bit the bullet and bought another replacement Rampage IV Extreme motherboard, which I'm glad to report works flawlessly. Not exactly the happy ending I wanted, but I'll keep the original board for spares and testing.