Showing results for 
Search instead for 
Did you mean: 

Rampage IV Extreme losing settings after power off

Level 7

I now have 3 boards with the exact same problem, Rampage IV Extreme, Z87 Pro, Z97 Pro. All operate properly so long as the power doesn't go off. When power goes off, bios is reset. Can't find the problem, it isn't the cmos battery, I actually have changed more than one and checked for voltage on board, batteries are good. Reflashing bios doesn't change anything. Must be a component that fails on these, anybody ever fix this?


Level 10

hey o/ been awhile, if you're Jollydet, noticed the avatar.

had the same problem until i changed battery, but if that doesn't work i dunno 😕

have you tried keeping it on stock, only changing 1 thing to check?

does it keep profiles?

very weird happening on 3 separate systems...

Watercooling FTW :cool:

"essentially one of the most hardcore overclocking motherboards ever made."

No, even if default settings are set with 1 memory stick and just the time set, it loses it. Tried reflashing, tried cleaning battery socket, different batteries etc. Nothing is fixing this. Definitely component level on motherboard but whats failed, that's the question