cancel
Showing results for 
Search instead for 
Did you mean: 

Rampage IV Exterme Dead! Suggestions??

Mark01
Level 7
Motherboard is only 5 month's old and hasn't been overclocked yet.
Working last night then this morning wouldn't start.
Has happened before and it was just a loose power switch connection at the motherboard coupler off the case but this time it wasn't.
There is lights on on the Motherboard and Graphic cards but won't start.
Had a tech bloke have a quick look at it and he just plugged a new power supply into board to see if it would boot and nothing happened.
Any other suggestions or am i in for a warranty claim 😞


Rampage 4 Extreme
Intel I7 3930k
Corsair AX1200
2x Matrix GTX580's
32gig Ripjaws Z (8x4g)
Corsair H100
5,162 Views
8 REPLIES 8

HiVizMan
Level 40
Are you getting any life on the two LED's at all? If so what codes are you seeing?
To help us help you - please provide as much information about your system and the problem as possible.

No life no codes just green led on motherboard is on nothing else. not event a whisper when power button is pushed

Myk_SilentShado
Level 15
Have you changed any of your hardware lately, even swapped something around?

Retired
Not applicable
Myk SilentShadow wrote:
Have you changed any of your hardware lately, even swapped something around?


Mm,.........

grottslampan wrote:
Mm,.........


I was thinking that the OP may have changed something around and his PC wasn't responding properly. Happened to me with my CHVF and all it took was a simple press of a button (though I needed a screwdriver to get it, video card got in the way lol)

HiVizMan
Level 40
RMA the board.
To help us help you - please provide as much information about your system and the problem as possible.

sorry. i was mistaken. only lights on motherboard is bios LED, start and reset button. nothing else.
What does RMA mean?

VistaKing
Level 9
Mark01

return merchandise authorization (RMA) . Meaning call Asus and open an RMA .


Created by DaemonCantor and Adam