cancel
Showing results for 
Search instead for 
Did you mean: 

Rampage IV Black Edition PCH Temp Concern

nnapior
Level 7
Hi all!

I recently just finished a water-cooled build using the Black Edition Motherboard. I have installed windows and other stuff at this point... But I've been going through BIOs and for some reason my PCH is idling between 39 - 45 degrees. Not sure if this is normal while using the water cooled profile. Just wanted to see if anyone had some insight on normal idle temps or tell me what they are currently getting.

Thanks in advanced! :D:D
5,926 Views
5 REPLIES 5

MeanMachine
Level 13
Hi nnapior and welcome to ROG.

That temp is a little high and should be ambient room temp +5 to +10c. It depends what cooling system you have (not listed).

If it becomes a concern and temps rise to unacceptable levels under stress, you would be advised to re-seat your CPU with new thermal paste using the pea method or upgrade your cooler.
We owe our existence to the scum of the earth, Cyanobacteria

My System Specs:

MB:ASUS ROG Crosshair VII Hero/WiFi GPU:EVGA GTX 1080 sc PSU:Corsair AX-1200i
CPU:
AMD R7 2700X Cooler: Corsair Hydro H115i Case: Corsair Carbide 780t

Memory:G.Skill TridentZ F4-3200C14D-16GTZR SSD:Samsung 500GB 960 EVO M.2


[/HR]

RobSys
Level 7
I also have a water cooled rig although I'm not running the water cooled profile (that crashes my system!) just running the CPU at 4.5 Gigs. I'm getting a PCH @ 40 oC. Seems to be fairly constant while idling. My CPU is at 33 oC and motherboard @ 31 oC. Doesn't appear to be presenting any issues...

Cheers....
Maximus VIII Formula, i7-6700K Clocked to 4.6+ GHz, EK EVO + XSPC Resevoir + D5 Water Cooling, 32GB G-Skill TridentZ F4-3200C160-32GTZB DDR4, Intel 750 NVMe 400G, 5, Seagate 3TB HDD + 4TB WD HDD, MSI GTX980 Ti Golden Edition.

HiVizMan
Level 40
Those temps are well within what I would expect to see. You are good to go.
To help us help you - please provide as much information about your system and the problem as possible.

Hi,

I've been currently having random freezing and pretty bad performance in general. I tried reseating all my ram, and GPU just in case that was a causing problems. They all seemed pretty good.

I downloaded HWinfo to check the hardware, and Ive found 4 temp sensors showing anywhere between 92- 100 degrees C. I have attached a screenshot.

Im not sure what the location of these sensors are.

Any help would be greatly appreciated.

Cheers,

~BS~

1stcowgirl
Level 7
Sorry for highjacking this but you guys sound like true pros and i cant find an answer anywhere.
so please forgive me but i have to ask..
regarding GPU-Tweak
Can I Import\Export Profiles to files?
want to import\export so the next time i wont have to start tunning evrything.

again, im sorry for jumping in like this.
ºi7-4790k, ºZ97-A, º4x4GB Ripjaws X 1600mhz, ºASUS GTX 780Ti OC [DC2OC] ºCorsair GS700, ºCM 690 IIIº LG E2241T ºWin 7 Ulti' SP1 x64