cancel
Showing results for 
Search instead for 
Did you mean: 

Rampage IV - BD-Combo not recognized

overdriven12
Level 8
Hi

I hope anyone can help me.

i upgraded my System to the following:

Rampge IV Extreme
Intel Core i7-3960X
32GB DDR-3 RAM Kingston Hyper Genesis
Samsung SSD 830
BD-Combo Opt.-Drive SAMSUNG SH-B123L

The big problem the Samsung SH-B123L has no hardware issue because i changed it 3 times at the hardwarestore.

In the Bios it is not found/listed and at windows 7 too.

I changed the sata ports, also the cables but it still not work 😞

please help!
3,947 Views
6 REPLIES 6

Raja
Level 13
Which ports have you tried so far?


Set SATA to IDE mode and see if the drive is recognized. Also update to the latest UEFI.

I've tried the black ports (sata 2).

The latest UEFI is the shipped one isn't it?

I forgot to say that it worked one time in sata mode but i needed to reinstall windows 7 because of the hardware upgrade.

Before i had a Rampage III Extreme.

Thank you for your help!

8_Pack
Level 12
You dont have to Reinstall windows when upgrading from X58 to X79 chipset.

8 Pack wrote:
You dont have to Reinstall windows when upgrading from X58 to X79 chipset.


My Windows Activation was buggy after the upgrade so i needed the reinstall 😕

Raja
Level 13
Latest UEFI is here:

http://www.asusrog.com/forums/showthread.php?6187-R4E-0803-and-079B-beta-UEFI-(BIOSes)

If that does not help, might want to try different ports and also debug with a different DVD drive if you have one. If that does not work then I would contact ASUS Support for your region.

-Raja

Raja@ASUS wrote:
Latest UEFI is here:

http://www.asusrog.com/forums/showthread.php?6187-R4E-0803-and-079B-beta-UEFI-(BIOSes)

If that does not help, might want to try different ports and also debug with a different DVD drive if you have one. If that does not work then I would contact ASUS Support for your region.

-Raja


Thank you very much!!

The 803 Update fixed it 😉