Showing results for 
Search instead for 
Did you mean: 

Rampage Extreme IV - Issues with PCI-E 3.0 , VSYNC ON, USB 3.0

Level 7
Specs First:
3930k @ 4.4Ghz (Prime Stable for 8+ hours)
32GB Kingston Hyperx 1600 CAS 9 DDR3 (took 8 sticks out of two packs totalling 48GB initially, all tested and verified good)
Three GTX 670 4GB Video
Vertex 2 240GB (For OS and testing for now)
Asus Xonar U3 USB sound
SilverStone 1500w power supply
Plugged in all power connections (EATX 4pin, EATX 8pin, Floppy power for DIMM's, PCI-E 6pin for additional slot power, 24pin, etc...)

Windows 7 64-bit SP1 (all windows updates applied)
Installed all software on CD for drivers and utilities (updated Intel chipset and Enterprise storage drivers)
Fresh and clean install (also using driver sweeper) of Nvidia 301.42 WHQL driver

BIOS version 1305 (had tried the latest BIOS but found this one to be stable)
(unless where noted below, all other values were set by "load optimized defaults":
--Mem BIOS Settings
Followed Easy O/C guide:
AI O/C Tuner Manual instead of XMP, set ram to 1.65v as on package, 1600MHz set manually
--CPU BIOS Settings
Turbo - By all cores can adjust in OS (Set to 44)
CPU VCORE Voltage - Offset mode (Sign is "+")
CPU VCORE Offset Voltage - AUTO
CPU VCCSA Voltage - Offset mode (Sign is "+")
CPU VCCSA Offset Voltage - AUTO
Load-Line Calibration - Ultra High
CPU Power Phase Control - Optimized
--Other options
Disabled on-board sound

Problem 1) Nvidia graphics instability
I've narrowed the first problem down that I may have one bad video card out of four when enabling PCI-E 3.0. PCI-E 2.0 I didn't have any erratic behavior in my old SR-2 system or this one. I honestly don't think the fourth card is bad, but so far the three cards left over have been good except the problem I describe below.

Now with three good running cards I have an issue now when vsync is enabled in any game. The video driver will crash and cause my system to hang and lock up. It appears that in-game vsync off, and adaptive vsync on seems to not cause this issue. Is there something with my CPU not clocking high enough or possibly turning speed step off that may help this problem? Should I disable PCI-E 3.0 and re-test? If disabling PCI-E 3.0 works, it sounds like I have a bad motherboard...? It may be worth mentioning that I did have PCI-E 3.0 stability issues before I started overclocking anything (but at that time I had my DIMM's at the default 1.5v which is way too low for my memory.)

Problem 2) USB 3.0 hard drives attach/detach multiple times in a second
These two seagate USB 3.0 drives have been flawless on my SR-2 system, my other SB ASUS system, and my Dell Laptop. I've noticed that when these hard drives are attached to my RIVE, that when I reboot the attach light (no activity light on the drives) will start blinking constantly like they are being attached and removed multiple times per second. If I re-attach them by removing the cable and re-attaching it the issue goes away, but I'm curious if this doesn't point to a voltage or stability issue that may also be causing me issues with the video cards and display problems. Also, every once in a while my wired 360 controller and mouse will periodically just stop responding (happened to me twice in the last 5 days) even though the devices still have power.

I have made sure my mainboard is not grounded out on the side of the case or at the bottom. Any suggestions on next steps?

Yes I plan on doing only one change at a time. Right now I'm going to reboot again (and probably one more time after that) not touching anything and see if it plays stable. If It does I'll move on to the next thing and repeat.

Also, the beta behaved a little worse for me (ram was screwed up so that could have been it), so I'm going to see if I can get stable on the 301.42 for now. Thanks for the help.

So I tried turning my AI Overclock (forget if that is the name or not) to XMP (thereby setting my ram to 1600) and making sure the voltage was at spec 1.65v and I had issues in my game benchmark.

Now memtest 4.2 did not fail, nor did prime95 after multiple reboots. So I was kinda at a loss here.

However this morning I noticed that since I'm running triple channel memory (and I have six sticks installed as the manual says which resolved my initial memtest errors) the first and last sticks were set to a command rate of 1T and the other four sticks were set to a command rate of 2T. I believe this ram is only 2T ram. Could having different command rates on RAM cause some weird system issues?

I've manually set the command rate to 2T to have all sticks be the same. When I get home from work I can do more testing. What do you all think about the command rate above?

So I've found out even with the command rate I cannot run 1600MHz on my RAM without the video card drivers crashing. 1333MHz is fine.

Also I don't have a bad card, but every time I put a fourth in and enable PCI-E 3.0 using Nvidia's method I keep getting driver crashes at the desktop. Are there any specific settings I need to enable in the BIOS to allow four cards to work properly in this setup (all PCI-E stuff is set to GEN3). I have a feeling I have a bad motherboard to be honest.

I know in my SR-2 I had to turn on my memory low gap to 3GB to get four working. I'm not sure that even applies here, but want to know the community's take on it.

Swapped motherboards, still no luck. Posted my complete issue to the Nvidia forums:

I'm going to try swapping the CPU next.

x79 isn't intended for 3.0 and there are some issues with full 3.0 compliance even though it can be made to hit the higher speed, that's why Nvidia disabled it and created a workaround for you to use at your own risk. It may take a BIOS release or two before ASUS and other makers work all of the kinks out...or it may never work correctly. There is a discussion at the link below.

I can't guarantee that is what is causing your problem but the fact that it works perfectly at 2.0 is telling.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

Agreed... however:

Have a look at Vega's machine. Other than running a 3960X and 680's we have a similar setup:

Interesting. Does it make a difference if you swap one of your 3 cards out with the spare? Does it fail with that card no matter which slot it is in or does it fail when any of the cards is put into the 4th slot?
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

It fails no matter which card I have plugged in the fourth slot. Been through all of that testing. Any three cards at a time works flawlessly.

I just replace the CPU and no dice either. This doesn't make any sense.....

How about the slot itself? If you only have one card on the board and in that slot will it fail at 3.0? Perhaps because it's further from the CPU or something? I dunno.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…