cancel
Showing results for 
Search instead for 
Did you mean: 

Rampage 4 Extreme DRAM error showing on board -_-

Benx70
Level 7
Hola

I recently got the new x79 mobo, and looks great but
Having a problem that won't let me boot .
The mobo LEDs showing A DRAM error, I
Have tried different mem.
I am now using 32 gig G.skill QAUD DDR3,
And I'm getting same problem.
I have even taken out the CMOS battery to
See if it might clear up any issues...


Hellllp !!!!

Thank you

Benx70
16,427 Views
16 REPLIES 16

8_Pack
Level 12
What is the rest of your system specs mate then we can see any other possible problems. I would try with bare minimum and the new ram firthest slot from CPU just one stick. So thats board, CPU, RAM, VGA only plugged in (To PCI EX1). All power connections made!!! I would also try switching to the second bios and trying to post with that.

hey guys i need some help here my debug lights give me 66 or 67 depending on the two sets of ram i tried.
I've tried the farthest socket for the ram clearing cmos, switching to bios 2 and clearing that ,and even the ln2 jumper any help would be greatly appreciated. I'm starting to think i just have a bad batch of ram but no way to test it right now...


specs
ASUS Rampage IV Extreme
ASUS ENGT430/DI/1GD3(LP) GeForce GT 430
G.SKILL Ripjaws X Series 16GB (4 x 4GB) 240-Pin DDR3 SDRAM DDR3 2133 (PC3 17000)
G.SKILL Sniper Gaming Series 16GB (4 x 4GB) 240-Pin DDR3 SDRAM DDR3 2133 (PC3 17000)
watercooling the cpu
Intel Core i7-3960X Extreme Edition Sandy Bridge-E 3.3GHz (3.9GHz Turbo) LGA 2011 130W Six-Core Desktop Processor

8_Pack
Level 12
I would remove the CPU first and check the socket for any bent pins. Remount your cooler being careful not to over tighten. Update Bios using USB stick flashback. Clear CMOS and then try again with one stick using the socket furthest from the CPU. Use only a video card in PCI EX 1 and power to all connections on the board. Try booting the board.

Are those Gskill series of RAM tuned for X79 I thought Gskills quad channel range was RipjawZ??? This may be where the problem lies.

Make sure also when you put the RAM in the slots you here two distinct clicks.

"I would remove the CPU first and check the socket for any bent pins. Remount your cooler being careful not to over tighten. Update Bios using USB stick flashback. Clear CMOS and then try again with one stick using the socket furthest from the CPU. Use only a video card in PCI EX 1 and power to all connections on the board. Try booting the board.

Are those Gskill series of RAM tuned for X79 I thought Gskills quad channel range was RipjawZ??? This may be where the problem lies.

Make sure also when you put the RAM in the slots you here two distinct clicks."

well thanks just looked over my manual thats what new egg sent me part of a bundle with the board and cpu so i guess im going to have to get a refund for the ripjaw x and get a diffrent pair. Tryed the sniper series because of the timeings being the same and voltage guess i have to get a refund on those as well but thanks. Now i just have to decide on a quad channel from the manual...

"I would remove the CPU first and check the socket for any bent pins. Remount your cooler being careful not to over tighten. Update Bios using USB stick flashback. Clear CMOS and then try again with one stick using the socket furthest from the CPU. Use only a video card in PCI EX 1 and power to all connections on the board. Try booting the board.

Are those Gskill series of RAM tuned for X79 I thought Gskills quad channel range was RipjawZ??? This may be where the problem lies.

Make sure also when you put the RAM in the slots you here two distinct clicks."

well thanks just looked over my manual thats what new egg sent me part of a bundle with the board and cpu so i guess im going to have to get a refund for the ripjaw x and get a diffrent pair. Tryed the sniper series because of the timeings being the same and voltage guess i have to get a refund on those as well but thanks. Now i just have to decide on a quad channel from the manual...

any links to a 8dim ram for this mobo?

8_Pack
Level 12
I am not in the states mate so I cant really recommend a link as I dont know what the e-tailers are like in the states. I use GSkill RipjawZ kits in my boards and they all work at the stock speeds with excellent stability. I believe all the RipjawZ series are tuned for quad channel use. So I personally would recommend them. They overclock really well too in my experience.