cancel
Showing results for 
Search instead for 
Did you mean: 

RAID issue RIVE?

Oxonsi
Level 7
I have the Rampage IV Extreme, but I am using a 3rd party RAID controller through one of the PCIe slots. I don't think my problem is even related to the RIVE motherboard, but I'm not sure where else to post this for any help/advice.

I've started having an issue with the game "Batman Arkham City". I store all of my games on a data drive, separate from the boot drive on my computer. The data drive is the one I have in a RAID 0 configuration through the PCIe RAID controller.

The problem is that when I run the benchmark utility in "Batman Arkham City", the program will freeze and a BSOD may occur. The BSOD is of the DRIVER_IRQL_NOT_LESS_OR_EQUAL variety, and the faulting driver is megasas2.sys. It therefore seems like this is a software driver issue, and I have tried a number of versions of the driver from the manufacturer. One of the older drivers does not seem to Blue Screen, BUT the benchmark will still freeze on me, and I need to kill the program. When I check the Windows System Event log, I find a number of Event ID 11 errors in the log that correspond with the benchmark freezing. These are I/O errors described as "The driver detected a controller error on \Device\RaidPort1". That could indicated one or more of the drives is failing, the controller is failing, or loose / poor cabling. I have checked the cabling, and it appears fine. I have also swapped the drives out for others, and they all seem to be fine.

The only remaining possibility is that the RAID controller itself is failing. But I don't think that is the case either because it reports its own status as "optimal" in the Management software. And in fact, so far the Event ID 11 errors only occurs when the "Batman Arkham City" benchmark is run, and I've executed a number of tests on the RAID 0 drive, and it always passes with no errors... The only real way (I know of to test this for certain) would be to swap out the RAID controller for another, but I don't have a spare, and its a $400+ part, so I'm not going to buy one just to test.

I don't think it is a problem with the game because it is relatively mature at this point, and I know it is upto date with the latest patches on my computer. I also don't find any others complaining about this issue with the game from my searches online.

And the other strange thing is that I know I've run the "Batman Arkham City" benchmark in the past without issue. That was probably over a year ago. So it seems something in my configuration changed that somehow conflicts with that game.

I know I could just avoid that game, since the problem seems to be isolated to it. But it makes me less than confident that everything is OK, and the last thing one wants is to experience a freeze and/or BSOD while working or playing on the computer. So I'd like to get this problem resolved, if I can. Just don't know what to try next.

I am on Windows 8.1 Pro x64 if that matters.

Thanks for reading.
1,402 Views
0 REPLIES 0