cancel
Showing results for 
Search instead for 
Did you mean: 

R4BE USB problem

qdemn7
Level 7
I have an Asus Rampage 4 Black Edition that is exhibiting a strange USB issue. I am running the 0801 Beta BIOS.

I have an Anker USB 3.0 Hub, and when the hub is plugged into a USB 3.0 port AND is powered up, the motherboard will not recognize ANY USB mouse or keyboard until it boots into the Windows desktop. So I can’t access the BIOS or Safe Mode.

I have 2 different illuminated keyboards and when the problem occurs, the LEDs do not light up until the Windows Desktop.

However if I disconnect only the power cord from the USB hub, there is no problem booting into and using the BIOS.

I can plug in the power cord to the USB hub once I am in Windows and don’t have a single problem.

If I reboot and leave the power cord plugged into the hubs the problem occurs.

I have changed multiple mice and keyboards, all plugged into the USB 2.0 ports.

Can anyone explain what is happening?

W7 64 Bit w/ all updates
Asus Rampage 4 Black Edition
i7-4930K Processor
32 GB of G.SKILL 1600 DDR3
Asus Strix 970 video card.
Thermaltake 1200 WO133 PSU
OCZ Revodrive 3 PCI-E SSD
NZXT Switch 810 Case
Custom liquid cooling system
Deck Legend LED Keyboard
Ducky Shine LED Keyboard
Microsoft 2000 Keyboard / Mouse Combo
Logitech Revolution Mouse
149 Views
2 REPLIES 2

neyuru
Level 10
I have a theory, the motherboard is designed to recognize only one usb keyboard at a time, or at most, one usb and one ps/2 keyboard, but not 2 usb ones. So when the power is off, the hub actually channles the first keyboard direct to the output and because the power is off, the second keyboard is "invinsible" to the the posting process of the UEFI.

When Windows is logged, it loads the necessary drivers for each of the 2 keyboards, something that the UEFI is not capable of.

[/HR]
Rampage IV Extreme BIOS 4206
Intel I7-3820
32 GB Quad Channel Kingston Hyper X Genesis
2 x Nvidia GTX 690
2 x WD Velociraptor 250 GB RAID0
Intel 120GB 320 SSD
Noctua NH-D14 SE2011
CM Silent Pro Hybrid - 1300W
CM HAFx

No, I didn't make myself clear. Even when i have only 1 mouse and keyboard hooked up, the system will not recognize them until it boots in Windows IF the USB hub is powered on. No power to USB hub, and no problems.

In any case thanks for your help. The manufacturer says the hub is defective and I'm RMAing it.