Showing results for 
Search instead for 
Did you mean: 

Problems with booting

Level 7
I just built a new pc about a week ago but I'm having problems with it. Usually it takes multiple times to even start the machine. Lights turn on and fans start spinning but after 2 seconds computer shuts down. After trying few times it starts normally. Also sometimes computer will start but I get no signal on my monitor and motherboard shows error code b2. When I finally get it to boot to windows I can use the pc without problems, playing games and stuff. Everything works.

I'm trying to locate to problem and so far I think it might be problem with my GPU or MB. When I started my pc without my GPU it booted on the first try. Then I tried to switch the gpu from PCIE x16 slot to x8 slot and it started without problems. Now I'm figuring is the problem with GPU or faulty MB pcie slot or something else.

Asus Maximus VII Ranger
i7 4790k
MSI Twin Frozr GTX 980
G.Skill Ripjaws 16gb(2x8gb) 1600mhz
Corsair 750w psu
Win 8.1

I haven't done any overclocking.

Level 7
Now I found that I can get it to boot when I press the power button multiple times in a really short period of time.

Level 10
What you describer definitely sounds like a power issue. Have you tried pulling everything out and running it with onboard graphics just to begin ruling components out? A long time ago I had an issue like that and it was my gpu shutting the ps down. I would discourage you from attempting to flash the bios while it is behaving like this.
Asus ROG Crosshair VIII Hero Wi-Fi Gigabyte X570 Aorus Master, AMD 3900X, EVGA 360 aio, 32gb G.Skill Trident Z Neo, Samsung 970 Pro NVME 512gb, WD Black NVME 1 TB, Crucial MX500 2tb, Zotac GTX 1080 AMP!, EVGA Nu Audio, CM HAF 932

Level 7
I'm gonna start believing that the Maximus VII series is not GPU friendly in many cases...