cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with Ai Suite III: USB 3.1 Boost missing

PiperTheGreat
Level 7
Hey all,

First post on this forum, I had resisted in doing so, as I'm big on self-help, and had tried to fix this myself, but I am stumped on this one

It's not a big issue, but it does surround USB 3.1 Boost, that comes inside of Ai Suite 3, with mine it is entirely missing, and my attempts to get it back in have not worked. Earlier last week, I had problems after installing the updates to counter Meltdown/Spectre, and had to re-install the Ai Suite 3, but it was seemingly a beta version or one that was not usually given with this board, but it works perfectly. Previously to that, any other version would result upon reboot, not having access to ANY USB devices, even in safe mode, requiring that I go back to an earlier restore point.

But fair enough, the new version works, and the PC is happy. But, today when testing the speed on a drive I noticed it was slower, I remembered USB Boost, but when looking it wasn't there

Tried extracting that component from a driver pack, but it didn't do anything, at most it briefly flashed up that it was going to start an install. I then tried using them ina part of the installer while selecting only the USB Boost component, and with any previous version to the current Ai Suite drivers that work, it again resulted in no USB peripherals working

How the heck do I get USB 3.1 Boost back on here while also not causing my USB stuff to break?

IF anyone can help, it would be most appreciated

Steven
2,502 Views
0 REPLIES 0