cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with speakers not working.

Blackcloud6
Level 7
I have a set of Logitech 5.1 surround sound speakers plugging in properly to the rear jacks of the computer. They were working properly until I plugged in a USB headset into a computer front panel USB port. After I unplugged this headset, I got no sound through anything but the Windows sound mixer shows sound going to the speakers (green bar moving up and down). I tried all setting and nothing,. I reinstalled the realtek driver and still nothing. Finally I was able to get headphones and mic to work through the front plug in jacks (not USB). But I still cannot get the Logitech speakers to work. I don't think the realtek Audio manager is even recognizing them as I do not see them in the top icons of device however the Jack icons at the bottom show the Logitechs plugged in.

I've read the bios setting made need to be adjusted,, if so how do I do that? And are there any other possibilities like a windows setting?

I'm running Windows 8.1 64 bit on an AMD processor.

Thanks in advance for your help.
1,550 Views
1 REPLY 1

Blackcloud6
Level 7
Oh this is embarrassing. 😮 I decided to to recheck all the speaker connections again and the one speaker with the power switch sits behind a monitor and turned a bit so I couldn't see the power light. The speakers got turned off somehow. I now got them working and can switch back and forth bewtween the head phones and speakers.

Silly me. :rolleyes: Disregard the need for help. :cool: