cancel
Showing results for 
Search instead for 
Did you mean: 

Pre OS USB mouse problem

Conners
Level 9
So I secure erased my ssd to clean install Win10. I also like to, after booting to the os install on a usb stick , go to repair my computer and choose trouble shoot to get to a command prompt to use diskpart to partition and format the drive then install the OS.

Herein lies the problem.. when I go to the trouble shoot icon my mouse quits working. It will not highlight the troubleshoot icon nor could I click on it to do anything. I messed with this for about 3 hours resetting CMOS re-flashing bios and such. At this point, frustrated, I tried used tab and enter to install the OS. Well it worked...So being a USB keyboard you would think the mouse would work also.

Went back and tried to reinstall the OS again doing a secure erase and so on with the same mouse problem. I guess my question has anyone had a pre os mouse problem , Corsair M65 RGB in this case.

What's strange is it works just fine on the 1st two screens the stops.

Thanks in advance!
2,902 Views
4 REPLIES 4

Chino wrote:
Try disabling xHCI.


Thanks for the reply Chino, my bad I should have mentioned that I have been in contact with Corsair on this matter. As reference here's what they wanted me to try. (without success I might add)


Please try the following and let us know of the outcome:
set USB to partial initialization - Moved from Full to Partial and partial to full.
- enable legacy USB support - Already enabled
- disable XHCI handoff (if available) - Already disabled and enabled
- update motherboard BIOS - Latest is installed 3003
- update your USB drivers if available and disable USB selective suspend through the Power Options within the Control Panel. - No usb drivers are needed/available for this board. and disabled selective suspend. By needed anything extra than provided by the? What chipset, windows, bios?, I don't know.

If the issue is still replicated, please consult ASUS Or Gigabyte and see what
settings they may suggest since the issue is only pre-Windows.


I should also mention I phoned tech support which unless it's a obvious problem is pretty much a waste of time IMHO. I never did get a straight answer. the Peep put me on hold and after a while I went back to like the start of waiting in line again. So I hung up. LOL

Which is why I am here today....

Not to mention I also tried an old Dell USB mouse as well as an old Razor MX518 mouse that had no problems as described in above posts.

In other words they worked!!!

Chino
Level 15
Here's the explanation.

Praz wrote:


Hello

Z97 and X99 chipsets now use xHCI for both USB 2.0 and 3.0 with updates to the xHCI protocol. Prior to these chipsets EHCI was used for USB 2.0. This change results in compatibility issues with some legacy devices and those devices require a firmware update to properly function with the latest xHCI implementation.


In order words. Ask Corsair for a firmware update. 😛

Chino wrote:
Here's the explanation.



In order words. Ask Corsair for a firmware update. 😛


I mentioned to Corsair when I contacted them that I thought I had either a CUE issue or right click (mechanical maybe) issue. A new cue was just released back in February. But I don't remember if I had it installed before I did a clean install of Windows or not. I did after re-install have an older version at 1st and probably the one Microsoft installed on installation. So that would mean those were also defective I guess or the mouse has a intermittent problem. I as I mentioned I talked to ASUS Tech support via phone to no avail so I wanted to post here just in case someone out there had a similar issue.

In general the mouse works fine in Windows. However sometimes on a reboot the mouse won't click on things, until I do a ctrl alt delete. Whay that gets it to working IKD.

Anyway thanks for your replies.