Showing results for 
Search instead for 
Did you mean: 

PCI-E runs at x8 instead of x16 (Maximus VI Hero Z87 Haswell) *Solved (See inside for solution)*

Level 7

Hello guys,

So nice to post here again after a few years.

I am writing to help other people specifically with the "PCI-E runs at x8 instead of x16" issue and report how I solved it.

To begin with, I was not even aware my GPU ran at 3.0 X8 mode instead of 3.0 X16. I found out b/c I recently bought a 3070 and I was updating my 3D Mark Advanced software in anticipation of the 3070 to run benchmarks and stress tests etc.

Then I noticed 3D Mark had a brand new test that wasn't there 4 years ago when I had last ran it, it is called PCIE EXPRESS FEATURE TEST. So I said to myself, let's run it and see how my system is doing.

So I ran the PCIE EXPRESS FEATURE TEST and I scored an average bandwidth of 6.56 GB/sec OoOoOoOo Immediately I realized smt was wrong so I ran GPUZ and indeed my PCIE slot was reported as running at 3.0 X8 mode when I used the stress test that comes with GPUZ to check it.

I guess you guys are gonna laugh but it turns out that my rig has been running at 3.0X8 mode since I installed my 1080 on my Maximus VI Hero back in 2017. I wasn't even aware b/c I am a veteran (dad) gamer and I only play World Of Warcraft and Civ VI. My nerfed 1080 was able to run WoW Classic at 3440X1440 100 FPS no problemo.

I suppose my GTX 1080 wasn't properly seated all these years and I never noticed. The Game Rock 1080 was a high-end special edition of 1080 with a massively heavy cooler that predictably caused my GPU to VISIBLY SAG. "Sagging" in English means that something is bent downwards (towards the ground).

I googled my issue and found the thread below

which is now locked. After going through the thread I decided to re-seat my card and in order to do so properly I have had to switch off and unplug my rig from the mains which on my rig has the same effect as clearing CMOS as the battery of my motherboard has long now drained.

After unseating and re-seating my GPU and plugging my rig back to the mains the issue is now solved and my 1080 is working at 3.0 X16 for the first time since I bought it. Note that I did NOT bother to clean the contacts or the slot with isopropyl alcohol as suggested.

- PCIE EXPRESS FEATURE TEST at 3.0 X8: 6.56 GB/s (BEFORE the fix)

- PCIE EXPRESS FEATURE TEST at 3.0 X16: 12.7 GB/s (AFTER the fix)

As you can see there's a big difference here and probably significant to someone who plays modern games.




i7-4770K Haswell running at stock

Maximus VI Hero Z87

Palit GTX 1080 Game Rock running at stock

2 SATA SSD's 2 HDD's in Raid 1

Acer Predator X 34 3440X1440

No PCIE devices at all apart from my 1080


I hope this post helps people. Thanks to ASUS for an awesome motherboard. My mobo is now 11 years old and still rocking.

I have no plans to upgrade my Haswell/Z87 combo atm.