cancel
Showing results for 
Search instead for 
Did you mean: 

PCI-E Issue With Crosshair Formula-V Z & Asus HD 7970 Platinum

Andie-B
Level 7
Hi everyone,

This is my first post and hope someone can help!

I have as part of my system an Asus Crosshair Formula-V Z motherboard and a single Asus HD 7970 Platinum graphics card.

The main issue is that it seems impossible to get the graphics card to run to where it should in regards to the PCI-E lane width settings.

I have looked through multiple forums and websites to explore the problem.

In the BIOS settings, (in advanced mode) the BIOS reports the card is running at a 4x speed under 3.0 conditions; fine, but the card can support 16x.

It is also in the correct slot, with no other PCI-E cards inserted in the system.

The BIOS now runs under the latest firmware as does the graphics card. Beforehand before the BIOS flash update, the card would run at 8x max under 2.0 conditions.

I appreciate that 4x/3.0 and 8x/2.0 give the same theoretical throughput, but why is the card being limited?

I have explored every part of the BIOS to try to see if there is a setting I've overlooked and can't see it.

The recent 3DPassMark tests were "okay" but dissapointing when compaired to other systems with the same CPU and same GPU. My scores are low compaired to others with the same components. I did the full tests through from Ice Storm through to Fire Strike.

Other information about the system:

32Gb RAM (4x Crucial Ballistix running at PC-1600 speeds with the correct timings throughout).
CPU is an AMD FX-8350 Octo-Core @ 4.0GHz.
2x Samsung EVO 840 Pro 250Gb SDDs.
Windows 7 64-Bit (SP1) with all updates.

I have tried running the system with nothing but essentials plugged in and everything at stock speeds and no overclocking (even though I don't really overclock much anyway).

I appreciate too that some have said that the GPU will idle at lower settings and ramp up as necessary - no problem, but a simple test under GPU-Z still shows it won't go higher than the 4x speed even if it does swiitch from 1.1 to 2.0 through the render test.

Any help from anyone is appreciated.

I have a system I built from scratch that I'd love to finally have right, and this is just irritating to say the least!!!!


Thanks all -- Andie
3,520 Views
4 REPLIES 4

kkn
Level 14
the Z board is a pcie 2.0 gen motherboard.
mount the GPU in first top pcie slot.
you will not notice enny performance drop or issue.

Tried as you said above.

Now reports as 8x 2.0 native.

Can't push it any further!!

Andie-B
Level 7
Hi KKN.
Thanks for your reply.

The card is located where it should be (16x slot directly below CPU).

I also appreciate that the Formula Z supports a maximum of 16x @ 2.0.

The weird thing is, that after the BIOS firmware update I did, the card now reports as 4x @ 3.0 native in the BIOS GPU POST. Don't know why, but presume the BIOS update has caused this reporting. I don't have enough information of all the updates the BIOS firmware update (#1403 off the top of my head) has contained in it.

I have disabled ULPS, no change to the card.

I ran a stress test on it this morning and the best the card did was 4x @ 2.0, this was with full GPU load and the fans slowly ramping up to maximum throughout the test.

That doesn't make sense to me - as that's no where near what the card should be capable of.

Any help will be appreciated.

Thanks all - Andie

kkn
Level 14
flash back to the last bios you had, no need to update bios unless its 100% need to do.
see if that works bether?
it can be a bug in the bios update too.