cancel
Showing results for 
Search instead for 
Did you mean: 

Patched TRIM in RAID! (Former: RIVE 3301 Patched for TRIM in RAID!)

Nodens
Level 16
Ok what you've all been waiting for 😛 After an insane amount of coffee and tea consumption I'm proud to announce, TRIM under RAID!

HowTo:

1. Download my modded UEFI image: http://bit.ly/VXz2cI (Newer links below, read the enitre post:))
2. Download F6 11.7 driver from Intel here: http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=3449&DwnldID=22194&keyword="Intel+Rapi...
(EDIT: There are newer driver versions)
3. Flash UEFI image via USB Flashback method (EZ-Flash won't flash it..like any modded UEFI).
4. Force install the 11.7 driver via device manager/have disk (You can use other 11.x versions BUT 11.7 is a must if you use Win8 due to a gazillion Win8 fixes it includes..Also I don't suggest anything bellow 11.6 as it's not made with the specific OROM in mind..)
5. Reboot and rerun the Windows Experience Index assessment (Windows uses this to figure out if the drive is SSD or HDD). (For Win8.1, run "winsat formal" in admin command prompt).
6. Go ahead and Optimize the array 🙂

Special thanks to my testers: jezjohnson and broken pixel!!


Disclaimer: This is my own work and is unrelated to ASUS. Also I am not responsible if this eats your data or makes you grow hair on your forhead..It has been tested enough but you know how these disclaimers go:p

Notes:
a) If you are installing a new operating system on the array the F6 drivers could probably fail, in that case install with a 3.x F6 driver and once installation finishes force install 11.x via device manager as normal.

b) You do not need to rebuild your arrays. It works with existing arrays as they are:)


The is only one image from now on. It includes both the patched OROM and the lastest UEFI Driver (Binary images: 12.0.0.1783 provided by Pacman, 12.5.0.1815/12.6.0.1867/12.7.0.1910&1936 provided by asder00 ). When you use the one, the other is not used at all, so there's no point making 2 versions.


All files moved from dropbox to Necrosan's server. I want to take a moment to thank Necrosan for volunteering to host them and accomodating all my needs!


The thread was getting too big and I was getting banned from dropbox for traffic every now and then heh. So new format, each board has a folder with all the mods for the board inside. Earlier versions are only OROM modded. those that come in 2 versions (plain and +UEFI) have either the patched OROM in the first case or an updated UEFI driver in the later. Versions after those have both.

New mods will be announced here.

Latest Rampage IV: 4310, Sabertooth:4210, P9X79/-Deluxe/-Pro/:4210, P9X79-WS: 3401

Repository:
--------------------------------------------------------------
RIVE: http://www.necrosan.com/rog/UEFI/RIVE/
RIVF: http://www.necrosan.com/rog/UEFI/RIVF/
RIVG: http://www.necrosan.com/rog/UEFI/RIVG/
Sabertooth X79: http://www.necrosan.com/rog/UEFI/Sabertooth_X79/
P9X79: http://www.necrosan.com/rog/UEFI/P9X79/
P9X79-Deluxe: http://www.necrosan.com/rog/UEFI/P9X79_Deluxe/
P9X79-Pro: http://www.necrosan.com/rog/UEFI/P9X79_Pro/
P9X79-WS: http://www.necrosan.com/rog/UEFI/P9X79_WS/
--------------------------------------------------------------
Patched OROMs for self-modding: http://www.necrosan.com/rog/UEFI/patched_orom/
They would work for any X79 board.
--------------------------------------------------------------


FAQ or Things you should read before asking questions

Q: Intel Toolbox is not working properly with this patch:
A: With this patch forget the Toolbox.

Q: How do I know if it working or not?
A: Installing Win8 and doing it's "Optimize" is the only verified method of triggering TRIM on demand. Anvil works for some drives and not for others on Win7. Most of the issues reported are with specific drives under Win7. To verify that the drives actually act upon the command you need to use the hex editor method as posted by Fernando here:
http://www.win-raid.com/t24f34-Easy-TRIM-test-methods.html
This method is the best for checking but it is a bit involved. A simpler approach for ordinary users is Trimcheck by CyberShadow: http://files.thecybershadow.net/trimcheck/
Source:https://github.com/CyberShadow/trimcheck

Q: My XYZ drive gets passed the command but the hex editor test shows TRIM has not been applied.
A: What drive controllers do with the command, depends on the drives.
If it doesn't work with your drives using this patch it would not work on ASRock and Gigabyte implementations as well and it's either a drive issue or Intel OROM/driver issue.

Q: Are there any drives /reported known to not work?
There is currently no drive known as not working.

NOTICE: Do not post ANY external links on this thread unless they point to Intel or a major manufacturer(drivers). I do not have time to personally verify any downloads other than the ones I make myself. Nor can I "police" the links in case they change to malicious targets at some point in the future. I can not support this unless I know exactly what's been flashed. Please respect this rule. I can not end up in a situation where I'm chasing an issue that doesn't exist because the user reporting it downloaded something else that may or may not be right.
If you want to send me new driver or OROM versions, use PM instead.
RAMPAGE Windows 8/7 UEFI Installation Guide - Patched OROM for TRIM in RAID - Patched UEFI GOP Updater Tool - ASUS OEM License Restorer
There are 10 types of people in the world. Those who understand binary and those who don't!

RealBench Developer.
325 Views
954 REPLIES 954

blakedj06 wrote:
I cant search this Site is to slow!


You can use Google to search this site for instance: site:rog.asus.com whatever keywords

Durzel
Level 7
Can only speak for my own experience but using 4102 BIOS when I installed Windows 8 it asked me early on in the install to provide drivers for the RAID controller (without me having to click "Load Driver", press F6 or anything). I selected the 12.6.0.1033 x64 drivers, install proceeded normally. I then installed the same 12.6.0.1033 RST without any issues.



Also works with Noden's latest modded BIOS that has the 12.7 OROM in exactly the same way.

Hmm i installed 12.6.0.1033 x64 drivers via Device Manager. After i install the 12.6.0.1033 RST Software with no success "This platform is not supported".

I have the same Board and the same Bios and the same OS (Win8 x64) whats wrong?

blakedj06 wrote:
Hmm i installed 12.6.0.1033 x64 drivers via Device Manager. After i install the 12.6.0.1033 RST Software with no success "This platform is not supported".

I have the same Board and the same Bios and the same OS (Win8 x64) whats wrong?

So we're clear, you're running "SetupRST.exe" aren't you?

Have you verified that the device is using the 12.6.0.1033 drivers in Device Manager?

Did you install Windows 8 in UEFI mode?

Nodens
Level 16
Seriously guys this has been answered a million times by lots of different people.. answering the same question over and over does not help those that do actually read the thread in order to troubleshoot a possible problem. We're 62 pages long and a lot of posts are repeated questions and people saying thanks (use rep for that, don't post Thanks) 😛 Seriously, use the search function first otherwise we'll get to 200 pages and it will all of them be a repetition of 3 basic questions. This is the last time I'm answering any question that has been answered 100 times before in this thread.

In UEFI mode installation, the application can be installed as is (by installing the full package).
In patched OROM legacy installation you have to install an RSTe version in order to keep the application and then force install the F6 driver through device manager. The full package installer is not compatible with the patched OROM, because the later still exposes device 2826 to the operating system.
RAMPAGE Windows 8/7 UEFI Installation Guide - Patched OROM for TRIM in RAID - Patched UEFI GOP Updater Tool - ASUS OEM License Restorer
There are 10 types of people in the world. Those who understand binary and those who don't!

RealBench Developer.

blakedj06
Level 7
Ok thx! I install now in UEFI Mode.

Which ME Driver Version is in your modded Bios? In Bios i see Version 7 but this is old i know?

Hi Nodens,

I am in a similar problem, but i read and searched a lot in this topic, but my problems is similar... not that it bothers me much, but would like to have the RST or RSTe application working showing me my drives... it's not...

I have installed windows 8 pro x64 using UEFI and everything works fine. I got 4102 modded bios with now the 12.7 OROM installed.

I tried installing the full package, but obviously, i am getting a "No compatible hardware found" message... thus, i installed the RSTe application then forced intalled the 12.6 RST driver, which everything works as planned...

But i not have both RST and RSTe applications installed... and both not showing my Raid setup... in fact, the RST is working and only showing me the optical drives i have, they don't show the Raid array.

And the RSTe when double click on the icon in the notification area, i am getting a service not running and if i open it i am getting a message regarding an unknown error opening this application...

I tried all above methods, and none are working. I know i am in UEFI, because this is how i did my installation of Windows 8. Never had to do an F6 to install on the Raid array... it always worked out of the box.

My Trim is working fine... and the PC is working fine with a stable 4.3ghz overclock (as in my sig). Would just have liked to the the RST or RSTe application to show me the raid array... but it's not...
Rampage IV Extreme (4802) + Core i7-3930K @ 4.3GHZ + Corsair H100i Push Config.
VCore = 1.33v | LLC = Auto | VTT = 1.10v | 2nd VTT = Auto | VCCSA = 1.10v | PLL = 1.78125v
G.Skill Ripjawz Z 32GB DDR3-1866 @ 1866 (8x4gb) Using XMP profile#1
Dual Corsair Force GT 120gb Raid-0 Sata 6G RSTe + 1TB WD Blue Sata 6G ASMedia
Dual Sapphire Radeon 6870 xfire - Cooler Master Cosmos II Case
PC Power & Cooling Silencer MKII 950w power supply.
Dell 2709WFP LCD Monitor (1920x1200) - Windows 8.1 Pro x64

Karl-Johan
Level 7
New driver and ROM is out! Over @ Station-drivers.

INTEL Raid/Ahci Controllers rom 12.7.0.1936
INTEL Rapid Storage Technology (RST) drivers 12.7.0.1022
Fractal Design North Svart TG * AMD Ryzen 9 7950X3D 4.2 GHz 145MB * ASUS ROG Crosshair X670E Hero * G.Skill 128GB (4x32GB) DDR5 6000MHz CL30 Trident Z5 Neo * Crucial T700 2TB M.2 NVMe PCIe Gen 5 * ASUS ROG Ryuo III 240 A-RGB * ASUS TUF Gaming GeForce RTX 4080 16GB GDDR6X OC Edition * be quiet! Dark Power 13 1000W * ASUS ProArt PA32UCX-K * Dali Mentor Menuet SE 2.0 * Windows 11 Pro x64 Canary Insider

tistou77
Level 13
Link here



🙂
Sorry for my english 😄


Case: Lian Li A77F
MB: Rampage VI Extreme Encore
CPU: i9 10980XE
RAM: G.Skill Trident Z RGB Royal 4x8Gb @4000 C16
GPU: EVGA RTX 2080ti XC Ultra
PSU: Seasonic Prime Ultra Titanium 1000W
OS: Intel Optane 905P PCIe
DATA: Samsung 980 Pro
SOUND: Asus Xonar Phoebus

Snakeyes
Level 11
Sorry about that. Wrong post wrong thread.
NAME THE SANDWICH: – White Bread, Lots of Baloney, Russian dressing and served with a small pickle.?


Intel Core i7 8700K @5.1 Stable Delidded
Asus Maximus X Code

16 GB
G skill TridentZ DDR4 ​4266 (PC4 34100)
Corsair HX1000i digital
EVGA 1070 GTX TiSuperclocked+
Samsung NVMe SSD 960 pro M. 2
Samsung 860 Pro
Watercooled with EK block radiator fans etc.