Showing results for 
Search instead for 
Did you mean: 

Oh Asus - facepalm

Level 8
So I decied after years of having AMD stuff only to switch to intel. It feels like a big mistake so far and the main reason is Asus Maximus VI HERO.

I bought:

- Core i7-4790K (4Ghz)
- Maximus Vi HERO
- RAM 2X 4Gb HyperX 2666CL11

I have from previous machine

- 2x Geforce GTX570
- Live GAMER HD (video capturing card)
- 1x 240GB SSD drive
- 1x 320Gb cheetah 10k drive
- 4x 500MB IDE drives

I am using fresh installation of WIN7 64bit.

Fact number 1 -> This motherboard is completely useless without flashing the bios to the newest version. God help people who does not know what flashing bios means.
It took me as least 8 hours trying to play with bios settings and connecting cards in/out to make it working before I gave up and decided for flash it.
It even did not recognize RAM modules parameters well.

Fact number 2 -> I downloaded/installed all the latest drivers from Asus web page.

Now what is going on after I flashed the bios + problems I was experincing before that ..

1. The only way how to make the motherboard to start is to turn the computer completely off. Resets gets mb into strange state with black screen.
Even choosing exit and reset from bios gets it to the same state.
2. Sometimes mb starts with first logo being kind of spread over the screen. It looks like old vga 640*480 resolution. It not possible to work in bios then, because whole screen is kind of shifted.
3. sometimes mb starts with logo in good format
4. in windows MB sometimes forgets USB devices I have connected in like Razer Magelodon headphones and there is no way to pop them up again without reboot.
5. mb recognized that I have this pci video capturing card, but it is displayed as PCI device and installing drivers did not help to make it working.
6. on-1board sound card is producing kind of glitch sounds during game playing like world of warcraft etc.
7. An attempt to make the raid working always makes windows to fail to blue screen during boot
My drives are connectedthis way sata 1,2 SSD/cheetach, sata 3-6 500MB ide drives
I went to the bios and turned sata into RAID mode. Then I went to the raid setup utility and made the raid using all ide 500Mb drives.
I made myself sure that my primary SSD drive is still as primary boot device.
If I turn the sata-raid mode off then everything works fine and my windows boots normaly.

It is now almost two days and I am still experiancing problems.

Can someone help me ? My Gr. cards arenot the newest, but two GTX570 are still doing pretty good. Can the problem be in my gr. cards ?

Level 15
The User Manual that comes with your Motherboard has instructions on how to flash the BIOS....did you by any chance happen to read it? if not, why not?

1. If you can boot into BIOS, hit F5 then F10. This will reset Motherboard Defaults and might help clear up any problems.
4. Go the the Tab marked "Boot" and disable Fast Boot, this will stop your USB devices from vanishing on you.
5. Is your video capture card a PCI model or PCIe model? if it's PCI, it's not compatible with PCIe slots.
6. Go to Control Panel, click on Hardware and choose Sound. Check properties are set to use the onboard sound and the correct amount of channels are set.
7. How on Earth do you have IDE HDD's connected to SATA ports?! the cables alone are incompatible.

5. Of course it is PCIe and there are no other ports than PCIe on board so no room for mistake.

Level 14
its the cpu and bios.
take a look in the main section i this forum section.
take a look how to flash so the mobo supports the new devils canyon cpu.
it does not come suppirted out of the box.

ssd - intel ports.
hdd and cd roms in asmedia ports.
use only the drive you have the operating system on to connect to mobo.
no other drives unless cdrom.

Level 8
An update here ->

Yes I read the manual, but manual is just repeating what I can see in Bios so except a few things not really helpful. DO not worry - I got through the flash procedure without problems except that downloadable bios files has too long name and you must go through more articles on the internet to know that you must first use some utility to shorten them. Which is of course not mentioned in the manual. 🙂
1. What I wanted to say here is > if i chose restart in windows so computer restarts, freezes before showing me the rog logo. If I am in bios and I chose save and reset during exit procedure I get into the same state. If I hit crtl+alt+del when being in bios so the computer resets, but it gets me still to the same state with black screen. I even tried resetting cmos by jumper on the board. It did not help either. Only powering computer down by button or choosing shutdown in windows telling computer to turnoff will allow me normal start next time I push power on. On the other hand it is not that annoying, because once I am done with bios so I will not need to ge there again for long time.

4. will try disabling fast boot (i am not sure now if I did it already) Anyway disabling xHCI solved the problem.
5. my video capture card is PCIe model for sure. Will check that out if I put it into right port. I hope not after so many years building my own rigs by myself. 🙂
6. This stopped now - the only change I made was uninstalling RST sw and disbaling xHCI.
7. Sorry for wrong info - of course they are SATA HDs with sata plugs. LOL now when I see what I wrote so I can not imagine trying to get IDE plug into sata plug hahaha

Level 15
No, if you flash your BIOS through EZUpdater tool, you do not need to rename the don't even need a tool to make it shorter, I dunno where you saw this but it's wrong as all you have to do is single click the file, hit the F2 key and give it a new name. The only time you need to use an abbreviated name, is when you use the BIOS flashback your case it would be M6H.

I flashed a Crosshair V Formula a few times without changing the file name, it was kinda long...but it never failed to work.

Level 40

Level 10
FACT 1, how can a Mobo that is older than a new CPU work without flashing it 1st?

jh30uk - True is I did not check how old the MB is. I though this Maximus series is not that old.

ehivar wrote:
jh30uk - True is I did not check how old the MB is. I though this Maximus series is not that old.

It has nothing to do with the Maximus name, the Mobo you have is a Maximus VI with Z87 Chipset so its a lot older then the recent Devils canyon CPU's so need updated 1st.

The newest is the Maximus VII with Z97 Chipset which should support it out the box.

Ne grateful Asus did update them to support the new CPU's because Intel wanted you to have to buy a new Z97 Mobo. 😉