cancel
Showing results for 
Search instead for 
Did you mean: 

Not Working - Maximus VII Formula

LouisC
Level 7
Issue: Motherboard, Maximus VII Formula, will not start. No q-code, no POST, no beeps, nothing except the red center light turns on (Republic of Gamers logo).

I bought a Maximus VII Formula motherboard end of March 2015 and it worked until end of June 2015. The motherboard was stuck with a Q-code of 00 and wouldn't POST. I RMA'd the board, ASUS tested it and said it was fine, they sent it back to me, I hooked it up and Q-code was stuck at 00, I RMA'd the board again and asked for a new motherboard.

I received the new motherboard a few weeks ago. I opened the new motherboard and installed it directly into my case. Once installed I noticed the On button had no light but the "Republic of Gamers" logo light was lit up. I tried pushing the On button and nothing happened. At that point I disconnected everything and removed the motherboard from the case and have it sitting in a cardboard box for testing.

I've gone through a number of steps trying to get any response from the motherboard:
- RMA'd the PSU. I have the new PSU hooked up.
- Tested the PSU with a multimeter and it does appear to be working correctly.
- Used a multimeter on several points and found the motherboard does appear to be getting voltage as expected.
- Changed the RAM sticks and the memory channels and tried without RAM.
- Tried without the CPU and fan and put them back.
- Tried with the graphics card and removed it.
- Downloaded the newest BIOS and put it on a FAT32 USB stick and put it in the correct USB slot as instructed in the manual. Pushed the BIOS update button and there's no flashing lights so I'm assuming the BIOS isn't updating.
- Tried holding the power button for about 1 minute.
- Hit CMOS reset and Mem Ok.
- Changed out every single cable.

Results: Nothing. Besides the "Republic of Gamers" logo light (I've attached a picture of what part I'm talking about) the board is doing nothing. No light/characters on the Q-code LED display, no beeps, the CPU fan isn't running, and the PSU fan isn't running as if there is no load.

Question: Did I receive a broken motherboard? Are there other things I can try? What could I possibly be doing wrong?

I really just want a working computer and would prefer not to have to RMA another motherboard. Any ideas are appreciated.

=== Parts info
Motherboard model: Maximus VII Formula

CPU: Intel Core i7-4790K 4.0GHz Quad-Core Processor

Memory kit part number (s) and amount in GB: G.Skill Ripjaws X Series 16GB (2 x 8GB) DDR3-1600 Memory

GPU: Asus GeForce GTX 980 4GB STRIX Video Card

PSU: Corsair 860W 80+ Platinum Certified Fully-Modular ATX Power Supply

CPU Cooler: Stock fan cooler and liquid cooling. Tried both. Liquid cooler is: Corsair H100i GTX 70.7 CFM Liquid CPU Cooler
===
5,725 Views
6 REPLIES 6

Nate152
Moderator
Hello LouisC

Welcome to the ROG forum.

No Q-code from the motherboard means one of two things either a faulty psu or motherboard. Since you rma'd your psu it looks like you have a faulty motherboard.

If you have the 24pin main power cable connected and still get no code:

Get on the phone with tech support and set up an RMA they're open 24/7.

1-888-678-3688

That is a real bummer. I'm just having the worst luck with these motherboards.

Nate152
Moderator
Yeah that's a shame LouisC but unfortunately there's really not much else to do, the sooner you get it in the mail the sooner you'll get it back.

I would tell them this is the third time and you're very frustrated over the whole situation. I don't know if that will help speed things along but it might.

Ask them if they can do a cross ship, that way you know you won't get the same board back.

Called tech support and the woman had no suggestions but didn't seem to want me to RMA the motherboard. Asked her for suggestions but she had none just kept saying it's very weird a board ASUS sends out could fail and am I sure the motherboard isn't turning on.

Anyways she said it's not possible to advance ship and said I can expect the motherboard back in about 4 weeks... 😞

Nate152
Moderator
Wow no suggestions and didn't want to RMA? Hmmmmm....

I know they used to do advanced/cross shipping unless they stopped it and I wouldn't see why they would.

Well I wish you the best of luck on a speedy return and please come back here and let us know if you have a working pc when you get your replacement motherboard.

4 weeks is a long time to wait.

onyxx
Level 7
Try conncect psu to the mobo on table without any other parts- cpu, ram, gpu...If maximus don't start then try diffrent psu...When don't start on another psu - mobo is dead...