Showing results for 
Search instead for 
Did you mean: 

New PC wont boot

Level 7

Hi all.

I'm repairing a PC I built for my father in law a few years ago. He took it apart fir cleaning and bent the cpu pins. Don't ask, idk why he thought removing the cpu was part of a routine dusting. Anyway... I upgraded the ryzen 5 2600x to a ryzen 5 4600g and it wouldn't boot without a bios update. Ordered an asus prime b550 plus to fix that as I had no cpu to work with for a bios update. 

  The new build shows the message in the picture, and the green qled light stays on. All other qled lights light up, then go off. I can't enter the bios using the f2 or delete keys during post. It won't let me into the bios, can't advance past the screen shown. 

 I've cleared cmos by jumping the pins, then removed the battery when that didn't work. Replaced sata cable and tried different sata ports. The mb sees the Samsung 860 Evo. Please help.

The build is:

Ryzen 5 4600g

Asus prime b550 plus, bios version 2806

2 sticks Corsair vengeance CMK16GX4M2B3000C15

Seasonic focus 450W gold

No video card

DVD player





Super Moderator


Odd - tried another keyboard?

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

I'm using a non descript keyboard from another functioning pc that takes no special drivers. So I think its not a keyboard issue.

 The OS is win 10, that was in use before he attempted his cleaning. With a cpu and motherboard change, could that cause this issue?

no, because you’re not as far as OS handoff. The system is waiting for prompt so I would at least try using a different keyboard if one is available. Or press f1 and not f2 😉

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Scone, you were correct about the keyboard, I plugged in another one and was able to get into the bios. 

 I got the message I posted on the new picture and after Googling the question I selected yes. 


Sorry had a glitch in my last reply. The pc now goes straight into the bios with no prompt from me. The OS will not load. By selecting yes for the  firmware tpm have I made a mistake and changed something in the processor I shouldn't have?

Thanks for your opinions, I need them.

This is the correct option@ "Y" to reset ftpm

Level 10

As you have a dvd burner it appears in the system, have you tried enabling the csm module and rebooting? 

Bish, I'm sorry but I'm not following what you are suggesting.  What is the csm module, what will enabling it do, and what section of the bios is it in?



Can see here as an example...