cancel
Showing results for 
Search instead for 
Did you mean: 

New MIVF BIOS 1002

Klaian
Level 7
I just notice a new bios uploaded on Asus site. Anyone know what was changed? I am having some minor usb3 issues and have held off on updating to 0903. Any information would be helpful.

Thanks
Asus Maximus VI Formula LGA 1150
Intel i7-4770K
G.Skill Sniper Series 16GB (2x8GB) DDR3 2400
Asus R9-280X DC2T-3GD5
Corsair Force Series GT 120GB SATA III SSD
Asus VE248Q Black 24" 2ms LED
Cooler Master HAF Stacker Modular Tower
OCZ ZX Series 1000W Fully-Modular 80Plus Gold
342 Views
17 REPLIES 17

HiVizMan
Level 40
You will not get a change log I am sorry. Sadly some of our competitors use ROG bios changes as a template for what they need to do to their own BIOS's and in the past the change log has been like a user manual for reverse engineering.
To help us help you - please provide as much information about your system and the problem as possible.

Ray_Proudfoot
Level 7
I'm sorry but this is totally unacceptable. We're not asking for information that would allow us (or anyone else) to reverse engineer the BIOS code.

All we require is a statement advising what changes / improvements the latest BIOS will make. Users are advised NEVER to update their BIOS unnecessarily which is why I won't change mine until I know doing so will resolve the frozen clock problem.

It seems Asus's self interest is more important than looking after their customers.Not impressed!

mcurtis
Level 7
Lol.. we started a thread on this on asking why they removed the 1002. I just went and looked and i still don't see the 1002 back.

http://rog.asus.com/forum/showthread.php?40136-Maximus-Formula-VI-Bios-1002-now-missing-from-asus-up...

dsp
Level 7
Hey mcurtis also here 😄
2nd thread about bios but still no answers ....damn.

mcurtis
Level 7
They are avoiding us! 😄

Breimeister
Level 10
I just went to the support website, selected downloads, then selected Windows 8.1 64bit and then downloaded 1002. It has the same properties as the file I downloaded a few days ago. If it was missing, it is missing no longer.

What is missing is the ROG thread about the raid SSD problems some users had with 903 and/or the 1002 bios.

dsp
Level 7
well just checked but no newer bios then 0804 is showing for me

OK you have the Maximus VI Formula, I have the Maximus VI Hero. I would guess the bios for the Formula motherboard needs some work.

I am still not tempted to try the 1002 with the Hero because of the SSD Raid problem I had with the 903 bios.