cancel
Showing results for 
Search instead for 
Did you mean: 

MRC update needed for M5G BIOS - screen flickering

zalbard
Level 8
Hi all,

for the last couple of weeks I've been going crazy due to the monitor flickering (losing signal for a brief moment of time).

I am using Maximus V Gene, 2x8GB G.Skill Trident X 2400, HP ZR30w, Intel HD 4000 (I also own GTX 690, but it is giving me the same issue).

After some searching, removing the videocard, RMAing the monitor two times, buying all the new cables, pulling my hair out and doing all sorts of things, I stumbled across this thread on Intel forums: http://communities.intel.com/thread/30096?start=105&tstart=0

Robert_U (Intel) wrote:
This issue is a BIOS issue specifically with the Memory Reference Code (MRC) version 1.4.0.0 or older. Please contact your system or motherboard manufacturer for a system BIOS update for your system or motherboard that includes MRC 1.5.0.0 or newer.


Apparently, the issue is related to a bug in Memory Reference Code (MRC) versions 1.4.0.0 and older. Versions 1.5.0.0 and 1.6.0.0 should contain the necessary fixes.

Please release a BIOS update ASAP! I am fully willing to beta test this.

Thank you.
12,857 Views
13 REPLIES 13

Chino
Level 15

Right now I am using:

MB: Maximus V Gene (tried BIOS 1101, 1204, 1309)
CPU: Intel 3770K
RAM: 2x8GB G.Skill Trident X 2400
GPU: Intel HD 4000
SSD: 120GB Intel 320
HDD: Western Digital WD30EFRX
SB: Auzentech X-Fi Forte
PSU: Seasonic Platinum 860
Keyboard: QPAD MK-85
Mouse: Roccat Kone+
Monitor: HP ZR30w monitor connected using DisplayPort cable

I tried two power cables for the monitor, and also two DisplayPort cables. Tried using GTX 690 also - same problem. I RMAd the monitor two times now (I am on my third one). Exactly the same problem.

Everything is stock. The system is LinX stable. DPC latency is fine. The -only- issue with the system is losing signal.

I should probably also mention that the problem can also occur in UEFI, so it's not a driver problem.

P.S. Make sure you check the thread I linked, the problem appears to be the same.

Chino
Level 15
Interesting read, indeed. So you've tried everything from the thread? Updated drivers for the iGPU, Using 1 stick of RAM, etc.? 😛

Drivers wouldn't help with getting the same issues after entering UEFI.

I actually found that thread just a few hours ago.

One stick of RAM I haven't tried, no. I am about to do Memtest again, then I will try that. It's not exactly a solution, though...

Zka17
Level 16
Hm... it's a strange thing... I've been using TridentX series kit (2x4GB though) in my MVG with no problem... I think, you should try first that single memory module mode... then If you have possibility, try an other memory kit too... - and run Memtest86+!

I am curious what MRC version is used in the current BIOS.
Zka17 wrote:
Hm... it's a strange thing... I've been using TridentX series kit (2x4GB though) in my MVG with no problem...

I think the issue is 8GB modules.

Memtest 5.0 is passing with flying colours. So it's not the RAM.

Once again, the system never hangs or BSODs. Everything is running flawlessly except for the monitor turning on and off at random intervals.

Also, looking at the thread at Intel forums, it appears that the issue only plagues those running large resolutions (1600p) or multi-monitor setups. Just something to keep in mind.

I think I just need a BIOS update. 🙂

t3kn33k
Level 10
have you tried the red go button for memory compatability

t3kn33k wrote:
have you tried the red go button for memory compatability

Isn't it only supposed to help in cases where the system doesn't boot at all?

Besides, my memory is supposed to be fully compatible with MVG...