Showing results for 
Search instead for 
Did you mean: 

Modified 2003/2105

Level 8
Anyone want to try a modded 2003 for Rampage IV Extreme?

It has updated Intel Raid and ASMedia.

ASMedia 106x AHCI ROM v0.951
Intel RSTe RAID ROM v3.1.0.2101

Only up-datable via flashback.

Currently running on my mobo.

2003 Modded / RST + ASMedia R4E

Link for modded 2105 w/Intel RSTe Rom R4E

Untested; try at own risk.

modded 2105 w/Intel RSTe Rom R4F
modded 2105 w/Intel RSTe Rom R4G

Got bored today, modded the formula and Gene bios 2105; they are untested since I don't have those boards so try at your own risk. I put the link on the top of the tread.

R4f bios u provided is not working , i am using Ez flash 2 and it says security check failed 😞
Intel CORE I7 3820 @ 4.2GHz -1.29 V
Asus Rampage IV Formula
Asus GTX 670 DCUT
Asus VG236H 120Hz
Asus Xonar DX
4x4 SAMSUNG 30NM 1866 8-9-9-21
Corsair Neutron GTX 125 GB
2x Seagate Barracuda 500 GB
Corsair H100
Corsair 400R
Corsair TX 650 v2

xt-107 wrote:
R4f bios u provided is not working , i am using Ez flash 2 and it says security check failed 😞

You need to use Flashnback and not EZ Flash 2. Please rename the file to r4e.cap before updating.
Change is the law of life. And those who look only to the past or present are certain to miss the future.

What he said, use flashback procedure. :-)Damn Captcha!
R4BE BIOS 0701 3930K @ 4.7GHz +0.005 XSPC Raystorm H20 block 16GB Corsair Dominator GT @ 2133MHz 9-11-10-27-1N SuperNOVA 1600 G2 XFX 290x XFX 290x 2x CL4100 240GB Intel RAID 0 Revo3 240GB XFI Win10 Enterprise TM HOTAS Warthog Slaw device BF-109 pedals TrackIR 5X270OC @ 2560x1440 @ 100Hz

Level 12
Thanks, working great here.
MB: ASUS Rampage IV Black Edition
CPU: Intel Xeon E5-2697 v2 (Cooled by Corsair H100i w/ Noctua NF-F12 fans)
RAM: 64GB G.SKILL RipjawsZ 1600 (10-10-10-30)
GPU: EVGA GeForce GTX Titan X Hybrid
TV Tuners: 2 * Hauppauge HVR-1800
Case: CoolerMaster Cosmos 2

Thank you UNIXSYSTEM. It worked great for me and I finally getting satisfied with the R4E.
I7 3930K @ 4.4 GHz - Vcore 1.272 V
Noctua NH-D14
Asus Rampage IV Extreme
Asus HD7950 DC2T @ 1085/ 5700 -Voltage 1.13 V
4x4 G.Skill RipsJawsZ 1600 - Voltage 1.4 V
2x Corsair Force GT 120 GB - RAID0
2x Seagate Barracuda Green 2000GB - RAID0
1x Samsung HD204UI 2000GB
Seasonic X-760
Azuentech X-Fi Forte
Chassis: Silverstone Fortress FT02
Display: Dell U3011

Level 10
What about R4F 2105 ? 😃
I7 3930k (C2) @4.5 1.32V/Rapmage 4 Formula/Corsair H80i + MX-4/4x4gb 1866MHz G.SKILL/SLI GTX 780Ti/ OCZ Vertex 3 MI 120gb(win) /OCZ Vertex 3 120gb(games) /2x seagate 7200.11 @ 560 raid0 (strap 128)/Creative Zx/Corsair AX1200w/Silverstone Raven 2 (rv02b-w)/BENQ EW2730/Windows 8.1 x64

Check my first thread at the bottom, I put the R4F and R4G modified links there.

Level 9
Ok... i flashed this and it worked flawlessly... UNTIL, i started AIDA64... which gave me a bluescreen on iastora.sys when it was reading Raid configuration.... it's a repeatable sequence, whenever i start AIDA64 it crashes like that, wasn't doing this before on 2003 bios with original bios.

I have to specify i was already using RSTe package) driver before on the 2003 bios, and with this new bios too...

Will try to update AIDA64 to the latest version and see from there, otherwise, that blue screen on IRQ_NOT_LESS_OR_EQUAL means something is wrong with the new option rom i guess, as AIDA64 probably validate something that makes the PC bluescreen...

I tried the latest Beta version i could download... 2.50.2063 and it works with this one, so i guess it's only related to AIDA64 hardware pulling...
Rampage IV Extreme (4802) + Core i7-3930K @ 4.3GHZ + Corsair H100i Push Config.
VCore = 1.33v | LLC = Auto | VTT = 1.10v | 2nd VTT = Auto | VCCSA = 1.10v | PLL = 1.78125v
G.Skill Ripjawz Z 32GB DDR3-1866 @ 1866 (8x4gb) Using XMP profile#1
Dual Corsair Force GT 120gb Raid-0 Sata 6G RSTe + 1TB WD Blue Sata 6G ASMedia
Dual Sapphire Radeon 6870 xfire - Cooler Master Cosmos II Case
PC Power & Cooling Silencer MKII 950w power supply.
Dell 2709WFP LCD Monitor (1920x1200) - Windows 8.1 Pro x64

Level 7
thanks! the gene 2501 mod is working super 😉
Asus Rampage IV GENE
i7 3930k @ 4.8 24/7
custom loop
16 gigs Trident X
HIS HD7970
2x OCZ Vector 256gb raid0 via UEFI
Crossover 27Q
Win8 pro