Showing results for 
Search instead for 
Did you mean: 

Missing Ram after Bios/CPU update - Crosshair IV Formula

Level 7
Hi Everyone -

I really need your help. I've been a happy owner of a Crosshair IV Formula for damn near a decade and she has treated me well. I know it isn't the fastest machine on the planet, but I have kept it clean system wise and it has always ran extremely well with an extremely overclocked 1090t in it until the water cooling system died on me and the 1090 was never the same.

I figured I would try the cheapest upgrade method possible - buy a FX-8350 and update my bios and it has been a rough ride since.

First - when I tried clearing post after the new CPU, it hung up and wouldn't post. I reseated the chip and nothing, did it a 3rd time (it was in properly the other times, but 3rd time is a charm) and it got past the CPU indicator. Now the DRAM light was going crazy and I still couldn't post. After moving to one ram slot, I finally got a post and entered the bios.

I have 4 4 gig sticks of ram at 1600mhz. I've tried every combination imaginable and can't get the motherboard to recognize them all. I can get it to recognize 2, any 2, but anything over 8 gigs won't show in the Bios. At first, when I loaded all 4 back in place, the BIOS said I only had 4 gigs, but after rearranging them I got it back to 8.

Windows 10 says that I have 12 gigs of ram installed with 4 gigs reserved for the system (I've never really heard of this but new to Windows 10). It also shows slot 1 as being empty (which it isn't, and I verified by removing the other 3 slots and booting without touching slot 1).

On top of all of this, it has my memory clocked at like 333mhz or something crazy low.

I can tell with the processor that it is an amazing improvement over the 1090t, but the ram issue is tripping me up and I need help.

My memory is NOT matched, but it worked with the old Bios - it would just be at the lowest possible settings (both are at 1600mhz but have different latency speeds). One brand is Corsair, the other Patriot.

Is there something I'm missing? I've been screwing with this damn upgrade for a week now and I need help badly. Even if I have to just buy new ram, so be it.

I upgraded with BIOS 3029 - which I assumed would be the most stable considering it is the latest (a whopping 6 years ago) and I've read that just about everyone can get this chip to run overclocked - I'm just running stock and it works great, but I'm 99% sure the ram situation has something to do with the Bios update. Is there a more stable version out there like 3027 or another?

Am I missing a BIOS setting? Did my MB obtain damage? Please help guys.

Thank you very much!