Showing results for 
Search instead for 
Did you mean: 

MEI failed to start on Z97-Deluxe (NFC & WLC) on Win 10

Level 8
recently Win 10 (Pro x64 1909 18363.836) updated my MEI drivers (to And since then the device cannot start (status_device_power_failure). I reflashed my BIOS (to the same, latest available version, 3503), updated MEI driver to, uninstalled (with driver removing) and reinstalled the device several times. Nothing helped. There was a couple of times when the device started successfully, but after a system restart it failed to start again.
I used the info tool (MEInfo) to get the status and these values are different from normal ones: CurrentState: Recovery; InitComplete: Initializing.
What could be the problem and how to fix it?

Level 8
Nice 🙂 Thanks a lot!

Level 7
Hi guys,

I am also having this. I tried all but the ME firmware update. Seeing that it wasn't successful with others, I don't dare updating the ME in fear of causing any more problems.
I tried debugging this a few years ago without any success but seeing others having the same issue is giving me hope.

I guess if we followed all that troubleshooting and the problem is still there, it could be just a hardware issue..

I might just build a new PC anyway. Maybe then I will start taking more risks to make this machine work properly.