Showing results for 
Search instead for 
Did you mean: 

Maximus VII Ranger soundcard issues

Level 7
Hi there! this will be my first post on here and i am kind of sad that it is one asking for help, anyhow.

I received my 4790k and Maximus VII Ranger yesterday and built together my PC, the problem now is that i am experiencing popping sounds whenever music/other sounds start and end, i have found numerous threads on Google about this issue.

The only way to stop these popping sounds is to uninstall the audio drivers from ASUS and run with the ones from Windows Update, this however leaves me without a HD Audio Manager and i want to be able to use it for its customization.
The issue is also resolved if i set "High Performance" in the Windows Power Options, but this leaves me with the processor at 4.4 GHz and full voltage 24/7.

I used to run with a Xonar D1 soundcard in my previous build to avoid issues like this, but the Ranger VII does not have a PCI slot.

Does anyone have any tips regarding this issue?

Full specs:
i7 4790k (L4 Batch for anyone wondering)
ASUS Maximus VII Ranger Z97
16 GB Corsair Vengeance 1600 MHz
EVGA GTX 780 Classified
Corsair TX 650W v2
Corsair Air 540

Level 7
I am having the same issue with the Hero VII.

This seems to be an issue with the driver. I have tried all of the drivers on the ASUS site and the ones that Realtek has on their site too; the issue remains the same with each of those drivers.

The only way to get rid of the popping sound is to use the default Windows 8 driver.

This is a really annoying issue for a board that is suppose to have "good" audio.

Level 14
I have been watching for this issue. Haven't bought anything yet. Looking at the formula due out soon. Saw this earlier and thought I would add this here:
MZ790E Bios 0904, GSkill F5-7800J3646H16GX2-TZ5RK, 13900KS, EKWB D5 TBE 300, Corsair 1600i, Asus Strix 4090 w/ Optimus block, Phanteks Enthoo Elite, Claymore 2, Gladius 3, XG349C, Samsung 990, Windows 11 Pro

Funny you should mention that... I have the same CPU with the Hero board and was also left with a D1 I noticed I didn't have any socket for. Now, my headset picked up some white noise before but the way it is now is just insane. With the Sonic Studio enabled, it cuts out at the start and end of me speaking as well as making the volume go up and down with other super weird ****.

So, un-installing the realtek drivers and going with the standard windows is the advised thing to do here? Really disappointed with you ASUS, fix your ****.

Same issue here. Any idea how to fix this issue on linux?

As an aside. I've never had so many issues with one piece of hardware as with this Maximus VII Ranger mobo. Bios corrupts the hdds partiation table on each reboot, raid does not work at all and now this sound issue. It's the first Asus hardware I bought and it will be the last one.

Level 9
Mine dont have that problems

Level 7
I have problems with Maximus VII Ranger. Cracking and popping sound all the time when sounds start from silent. Very irritating when chatting etc. where short sounds are played frequently, causing popping everytime. I have tried different realtek drivers but no luck. Worked when I uninstalled Asus and Realtek's drivers completely, but then sound didn't work in Skype anymore.

Level 7
OK, I have the same problems with my Maximus VII Ranger. I hear broom pitch noise which sounds like a dial-up modem (establishing a connection) whenever there are changes on the screen. This happens after the OS(Windows 7 Ultimate x64) has started the audio driver. In BIOS and while loading the OS there is no noise, it's dead silent.
I have tried reinstalling two different versions of audio drivers (the latest and the previous uploaded on the Asus website) and the problem is still there and very annoying. I also tried reinstalling all the drivers, but no success in fixing this issue. Then I tried replacing the default 1104 BIOS with another 2012, which didn't solved anything but it blocked my LAN. There was no Internet connection, the DHCP was not working and when I set the IP/DNS addresses to manual there was no internet traffic. So I flashed back the BIOS to 1104 and the LAN was fixed. While on 2012 I also tried with reinstalling the drivers, but that didn't helped. And here am I here complaining and asking what to do? If there is no fix then I should go and RMA my mainboard.

The configuration of that PC is the following:
Maximus VII Ranger (BIOS ver. 1104)
i7 4770K @4.7GHz
4x4GB Kingston BeastX @2400MHz CL11
Sapphire Radeon 290X @1175/6200MHz
3xSamsung 850 Pro 256GB @RAID0
WD Caviar Black 2TB
Dell U2713HM
JBL LSR305 active studio monitor speakers

Level 7
I have the popping sounds problems with my Maximus VII Ranger too.

Test it in play windows sound whit front panel headphone.