cancel
Showing results for 
Search instead for 
Did you mean: 

MAXIMUS VII RANGER don' see M2 SSD

Vishez
Level 7
Hello
I have MAXIMUS VII RANGER moterboard and Plextor M7V M.2 2280 Sata SSD. I put M2 ssd into slot M2 on motherboeard but it does not appear in bios. I change PCI mode into M2 mode - still not see. In manual said that MAXIMUS VII RANGER accept M.2 2280 SSD. This SSD normal and work correctly on another motherboard. I try different things but still not bios not Windows installer didnt see M2 SSD. What I need to do that bios can see this SSD?
20,662 Views
7 REPLIES 7

Chino
Level 15

Chino wrote:
The Maximus VII Ranger only supports M.2 PCIE SSDs. It doesn't support M.2 SATA SSDs.


And why there is M2 slot on it if it doesnt support M2? For what type of hardware it?! And as I understand if i buy M2 to PCIE adapter I can use it in M2 mode in bios in PCIE slot 4? And how much i lost in speed if it not be M2 ssd in M2 slot but M2 in PCIE adapter in PCIE slot?

I buy Asus HYPER M.2 X4 MINI CARD and insert it with M2 SSD into PCIeX4_3 (Black). M2 mode turn on. And still nothing! Bios dont see M2 ssd. Power on ssd supply cos he is a little warm. So what next?! What I need to do that bios can see M2 ssd?

Vishez wrote:
And why there is M2 slot on it if it doesnt support M2? For what type of hardware it?! And as I understand if i buy M2 to PCIE adapter I can use it in M2 mode in bios in PCIE slot 4? And how much i lost in speed if it not be M2 ssd in M2 slot but M2 in PCIE adapter in PCIE slot?


The M.2 ssds can use either the sata protocol or pcie protocol for bus communication. Your motherboard supports the pcie protocol via the M2 slot. But your ssd uses sata. With the adapter you need to change your pciex4 slot from M2 mode to x4 mode. Hopefully it will be detected that way. But since it's a pcie adapter I fear you still need a M2 ssd which uses the pcie protocol.
Asus ROG G55VW:
CPU: i7 3630QM
GFX: Geforce GTX660M with 2GB ram
RAM: 2x8Gb 2133MHz Kingston HyperX Impact (surprisingly the G55VW uses the 2133 X.M.P. profile)
Storage: RAID0 with 2x 256Gb Crucial SSDs (both msata, one in a sata adapter)
OS: Windows 10 x64

FuryA
Level 8
another suggestion is you can us tM.2 (NGFF) SSD to SATA adapter

MANKIMZ
Level 7
hello.
i've just buy an XPG sx 8200 ssd which is m2 pcie . after i install the ssd to my maximus vii ranger motherboard it don't detect the ssd even after i've update my bios. when i check the computer management it appeared the nvme controller which is under the storage controller have this yellow warning triangle indicated that the device can't start (code 10)-An I/O adapter hardware error has occurred. can someone help me regarding this problem?

targaid
Level 7

I've just bought a WD_Black SSD. It is PCIe but the board still isn't finding it.  Any advice?