cancel
Showing results for 
Search instead for 
Did you mean: 

Maximus VI Formula USB (3.0) Issues (XHCI and other)

Kosodm
Level 7
Hey Guys, first off thank you for taking the time to read this post as this issue has plagued me for going over a week now. I would like to start by saying that I have scoured the internet up, down, left and right including these forums and cannot find a working fix for my issue following every applicable troubleshooting step found in other posts and sites.

The issue I am having is that I cannot get my USB 3.0 functionality to work. To not flood this post with to much babble I will list my configurations / scenarios and then what takes place and I am just hoping that someone can point me in the right direction.

---I have already done a full format and reinstall of my OS of choice - Windows 7 Ultimate x64 SP1 - with all the latest updates to the date of this post. I have updated to the latest BIOS update provided on the support section for this MoBo and have tried SEVERAL driver combos both provided from ASUS and others (possibly there is one out there I missed, thats why I am here) I have set USB Initialization to "Full" and ensured all ports are active within BIOS.



---Legacy USB - Enabled ---xHCI Mode - Smart Auto ---EHCI - Disabled = This config will RANDOMLY after initial bios ROG screen will say "No keyboard detected" and sometimes not but either way mouse, keyboard and usb ports will not work in OS but do in the BIOS. I used a mouse server program to control the mouse with my smartphone and can see that the Intel extensible host controller states "Error 10 device cannot start"

---Legacy USB - Enabled ---xHCI Mode - Enabled ---EHCI - Disabled = This config will ALWAYS after initial bios ROG screen will say "No keyboard detected" and mouse, keyboard and usb ports will not work when entering OS or BIOS, this calls for a CMOS clear. I used a mouse server program to control the mouse with my smartphone and can see that the Intel extensible host controller states "Error 10 device cannot start" when in the OS

---Legacy USB - Enabled ---xHCI Mode - Disabled ---EHCI - Disabled = This config will work without issue. It will load to OS without any POST error messages and allow the keyboard and mouse to function within the OS and BIOS on each boot but every port works as USB 2.0 (I understand why)


Again I'm sorry for the long post I just wanted to ensure whomever may offer me advice or assistance understands that I have truly tried everything I have been able to locate on this forum and elsewhere to resolve this but I feel as if I am missing something here. I have tried not loading the OS with any USB devices attached and everything else under the sun. I have even fully taken apart the build to ensure everything was connected correctly and no shorts were possible. The machine suffers from no other alignments and all ports work with the last combo provided.


Is there a BIOS setting causing this to happen? Is there a version of driver for this board whether it be chipset, MEI or USB 3 controller (or combo of the three) that will resolve this? Is there a sequence of events that will take me to the promise land? Please help me lol I'm at my witts end. I have even tried to reinstall MoBo CD provided drivers with no luck here. The main issue here is I am unable to get a stable XCHI controller installation. They all seem to report Error code 10 under various circumstances/configs.


I would just hate to purchase a $300 dollar plus motherboard only to discover USB 3.0 functionality provided is not an option.



Build Information (If it helps) - Windows 7 x64 Ultimate All Updates - Latest BIOS provided by Asus Support. Latest Drivers Provided by Asus Suport (Keyboard and Mouse are Logitech Wireless combo but have tried hard wired vanilla set as well)

---CPU

Intel Core i7-4770K 3.5GHz Quad-Core Processor

---CPU Cooler

Noctua NH-U12S 55.0 CFM CPU Cooler

---Motherboard

Asus Maximus VI Formula ATX LGA1150 Motherboard

---Memory

Corsair Vengeance 16GB (2 x 8GB) DDR3-1600 Memory

---Storage

Crucial M500 CT960M500SSD1 960GB SATA III MLC Internal Solid State Drive (SSD)

Seagate Barracuda 1TB 3.5" 7200RPM Internal Hard Drive

---Video Card

MSI GeForce GTX 770 2GB TWIN FROZR Video Card

---Power Supply

Corsair 760W 80+ Platinum Certified Fully-Modular ATX Power Supply

---Optical Drive

Asus DRW-24B1ST/BLK/B/AS DVD/CD Writer





Please let me know if there is any more information I can provide to help. Thank you again for your time.
3,275 Views
2 REPLIES 2

Praz
Level 13
Hello

If connected USB devices correctly work with xHCI disabled but malfunction with xHCI enabled it indicates that the problematic USB devices do not conform to Intel's xHCI specifications. The USB devices will need firmware updates from the device manufacturers.

Thank you for your quick response! But I don't believe that is the issue as its not only certain devices but the xHCI (Intel USB extensible Host Driver) as a whole reports "Error Code 10 - Unable to Start Device" within Device manager and then none of the ports, whether they be 2 or 3 pots, work.