cancel
Showing results for 
Search instead for 
Did you mean: 

Maximus V Formula SATA Help

Stickman64
Level 7
Hey all,
I've got a Maximus V Formula new that I bought to replace an old Z68 Asus board. I went with the older board because my
i7-2600k is still cranking and overclocks well. I've got two issues I can't figure out:

1) The BIOS does not show the SATA drives hooked up to the Intel controllers. The flash screen for RAID during boot shows them, they boot fine, show up in Windows okay, runs okay, everything. However, when you are in the SATA screen where you change from IDE to AHCI to RAID, they don't show at all. I've flashed to the latest BIOS and still the same.

2) I wanted to use Intel's Rapid Storage to cache my hard drive like I did previously with the Marvell controllers on my Z68. I boot to the SSD but then cache the 2 TB as well. It worked great with the Marvells but I can't get it to work with the Asmedia 1061 controllers on this board. I have downloaded driver after driver and the drives don't even show when you are in the Intel Rapid Storage Technology application. It only shows the two SATA drives on the Intels and my optical drive. I've read about changing BIOS settings from ROM but can't find that option anywhere. Again, the drives show in Windows and work fine but there must be some RAID setting I'm missing.

I really don't think it's the board because everything works fine. It's too late to RMA to Newegg and they don't have anymore. The only socket 1155 that they have is an AsRock and I'd rather keep this one. It matches my Strix 970 well.

Any ideas?

Shawn
1,682 Views
0 REPLIES 0