cancel
Showing results for 
Search instead for 
Did you mean: 

Maximus IV Extreme-Z = DOA ?

Retired
Not applicable
Hi, I am new here and have had ROG Mobos since the buggy 680I 😛

I normally buy all my hardware from OCUK but for few years now (3 on Xmas) I decided to not simply upgrade for the sake of it every time something new came along so kept on my P45 MF II ROG and Q9650 +8GB Memory but last week the itch got too much and I started to read up on the Z68's.

Anyhow I bought all my hardware from Amazon.uk as it was far cheaper and they have good service and are fast at deliveries added to OCUK did not have all parts in stock.

I got all my hardware today apart from new case which I need to fit this E-ATX Mobo and I picked a case today but its from elsewhere as out of stock at Amazon.

The big outer box was opened by myself and the Intel I7 2600K retail CPU box was a bit crushed and worried me but then again the CPU would not be hurt only cooler but it all looked fine when inspected.

The Mobo box was not sealed (cannot remember if they are sealed to begin with).

Something worried me in way box was with flaps worn as if it had been opened but all extras were sealed in bags and not used but that is not to say Mobo was same story!

I spent all day removing my devices from my current installs (dual boot) so I can do a quick swap of hardware on old OS and format in weeks to come.

I then put the new hardware together on my bench and began test to see if all is well and to date I have never had anything DOA but the Mobo span up CPU/GPU fans for about 5 seconds and then stops with a lit LED at 24pin socket area for a CPU error (this was with the Intel cooler (then later tried my aftermarket cooler) so nothing shorting as there is no backplate etc on the Intel cooler.

It has no readings on the 2 digit debug LED screen and I removed the CPU and everything is fine looking but same thing no matter what I did and I tried everything inc resetting CMOS with battery removed+jumper but I have has not 1 bios screen post.

Primary PSU is an Enermax Infiniti 720watt but tried a lower spec spare one and same issue (both run my old hardware)!

I have read one other peep here had same issue but I am not going to go through all that with Amazon messing me about waiting on a repair or someone taking weeks to test as right now I am stuck with my old parts on the bench without a case and running in safe mode as I do not want to install all devices then remove once again if I can get a replacement quickly.

IMO a brand new out of box DOA (I cannot prove if Mobo or CPU as no spares of either) should be replaced within days not weeks.

I am very disappointed and have had a wasted day and night and now running parts on a bench at 1:25 am just to post this.

I am looking for advise as have not dealt with Amazon for any issues before and unlike OCUK they do not have a person you know at other end of the phone!
3,591 Views
2 REPLIES 2

Raja
Level 13
Not sure what memory you are using but I would try this:

1) remove power from the board
2) remove the CPU
3) Clear CMOS with CPU removed.
4) remount CPU cooler.
5) Insert one memory module in the slot furthest from the CPU.
6) Power up the board and see if it will POST.

If it will not POST after those steps then RMA it or contact ASUS Support UK...

-Raja

Retired
Not applicable
G.Skill RipJawsX 8GB (2x4GB) DDR3 PC3-12800C7 1600MHz Dual Channel Kit (F3-12800CL7D-8GBXH) x2 (16GB)



I tried that mate and more, have 16GB here (4 modules) and tried 1 at a time in each slot and swapped modules in case a bad one but at end of day its a CPU error LED not I get.

I know from reading in past 10 years that Asus support is not to hot and luckily I have never had to use them (hoping this new forum changes this).

It turns out Amazon got back to me during early hours and their policy is 2 new items (Mobo+CPU) will be sent out free of charge as A.S.A.P and I have to return the faulty items within 30 days (already arranged for pick up on Wed at their expense)!

Only issues is CPU seems to be in stock but claims "may need an extra 2 days" or words to that effect for whatever reason!

At end of the day these things happen but its still a PIA! :cool:


Are you the same peep that was on the MF II massive thread on XtremeSystems Forum?