Showing results for 
Search instead for 
Did you mean: 

Maximus IV Extreme p67 USB 3.0 fail

Level 10
Ok just randomly super reset cmos a bunch of times/installed a bunch of random stuff, also changed out mouse, usb ports working again, thats it for today, USB 3.0 does not like the Razer Taipan and bugs out mouse, even though it used to work flawlessly in this rig.

Switched to a Thermaltake Theron mouse and mouse works fine in all usb 3.0 ports.

May be all ill do for awhile but don't know.

Original Post:
Ok, Asus really needs to look at this.
Apparently a firmware update on the usb 3.0 May work, but I can't figure out what firmware update I need, as all the other links also are gone. or redirects me to main site where they were.

Also I don't know what usb controller I have, such as this "uPD720200A" as I don't know where to find it.

Next, I tried just a download to see if it would work, but I got plural host controllers were detected so I have 2 host controllers or something as well according to some google looking, so no way to figure out how to get around that.

M IV E P67, USB Ports fail
So, it's been a LONG time since I came to the forums, because honestly asus rma failed me and put me through 3 years of pain for a simple RMA or fix.

This problem has been here for awhile for what I am about to discuss and RMA is simply not a option for me anymore with Asus in my eyes.

I have the P67 Maximus IV Extreme
This mobo has been know to fail on USB Ports, a few times I was able to fix it, and now I can't get it to work anymore.

USB 3.0 ports don't work or also do not work properly, meaning lets say I plug my mouse in a USB 3.0, My mouse does not work right and a small touch of it will make my mouse go all over screen without control of it.

Usb 2.0 also now failing, By this I mean if I put computer to sleep half hour or more, it takes time to Warm up the USB Ports and allow my mouse to move without stutter, meaning if I Move my mouse it will stop by it's self, then a slight moment like 1 to 2 secs it will move again, then do same thing, till it works within a couple mins, this use to be 10+ mins before I completely reformatted, but also had this problem in past.

Bios update, and fresh install of drivers ect. does not work, this is how I fixed it a bunch in past, but now they simply fail.

Asus has not given any public word to a fix or a update ect. to make the mobo work correctly again.

I honestly do not use this computer anymore because of these issues, and it's not my fault, it's sad to see my main computer I built years ago become utterly useless to me because of this, and knowing how asus RMA handles things.
I would get into details but it's not suited as I had to take Drastic measures to finally get my GPU's RMA'ed and sent new ones, even a upgrade cause I had solid proof working with MULTIPLE asus reps over the years and showing proof I was not the only one with the problems. Asus just wanted to mess with me it seemed as it was not with just ASUS gpu's either, it was the entire 560ti series across multiple companies who HONORED the problem and asus would not.

But simply back onto topic, Does anyone know what to do besides RMA, maybe something i missed, Ive tried bios, ive tried uninstall of drivers and update after a CMOS reset, ect. which worked in past, but honestly, I do not want to RMA, Asus honestly screwed with my head in past, and lost my trust for awhile.

Any help though would be appreciated, and if someone at Asus wants to talk to me as well please feel free to.

I don't mean to be rude about it but im giving the straight facts of my experiences after all that and it displeased me in so many ways I had to stop visiting a community I once loved, and now hopefully get back into it.