cancel
Showing results for 
Search instead for 
Did you mean: 

Maximus Hero VII Memory Issue

BrianSiano
Level 7
I've started getting alerts about memory issues on my system, so I bought a set of 32gb memory DMMs to fix the problem and upgrade. Since I can't find any up-to-date lists of memory/mobo compatibility for the Maximus Hero VII, I got Corsair memory with the same specs as my old memory (240-pin, 1600mhz).

The machine would not boot with the new memory at all. It'd start up, hum, but nothing. No beeps, either. Reinstalling the old memory got it to work.

Now, this was the _second_ time this had happened: I tried upgrading my memory a year ago, but I figured I'd gotten a bad batch of Corsair memory. But twice? I'm wondering if there's a problem with my motherboard. Am I doing anything wrong?

(And if I have to replace the motherboard-- well, would it be worth it to upgrade to a new mobo, CPU _and_ memory?
1,652 Views
2 REPLIES 2

Nate152
Moderator
Hi BrianSiano

Welcome to the ROG forum !

Power down your machine and install your corsair memory, hold the clear cmos button for 3 seconds then try booting.

How does it go?

Please list the complete specs of your pc and both kits of ram or post links to them.

It worked PERFECTLY! Now I can edit video with 32 gig of RAM! Again thank you!

Nate152 wrote:
Hi BrianSiano

Welcome to the ROG forum !

Power down your machine and install your corsair memory, hold the clear cmos button for 3 seconds then try booting.

How does it go?

Please list the complete specs of your pc and both kits of ram or post links to them.