cancel
Showing results for 
Search instead for 
Did you mean: 

Maximum IV Extreme-Z - PCIE Bus Speed in Windows 10

Stu
Level 10
Hi Guys,
Just upgraded to 10 pro from 7 ultimate.

Running triple AMD 7970's all underwater.

Asus dont offer any chipset drivers for Win 10.
Is that normal?

Ive got it all up and running cleanly, no problems, but I have no crossfire options in the AMD software.
Ive unplugged one card to try and help diagnosis as triple cards can be hard work, wheere as 2 are normally easy.
I have now noticed one card is at 16x and the other 2x on the PCIE bus.

The software still wont offer me crossfire support.
I have a feeling this is chipset driver related... But there are none to change!

can anyone help at all?

Asus Maximus IV Extreme Z
i7 3770K @ 4.4ghz
AMD 7970 HD x3 in TriFire @ 1200/1800.
2x 240GHZ OCZ Vertex 3 SSD & 1x 512Gb Vertex 4
16GB 2133mhz Patriot DDR3
Ennermax Max Revo 1500w PSU
Huge water loop with an internal EK 340mm & external Supernova 1260mm
Windows 7 64 bit.

Aquaero Fan control & monitoring
1,374 Views
2 REPLIES 2

SaLSouL
Level 10
Stu @ MSD wrote:
Hi Guys,
Just upgraded to 10 pro from 7 ultimate.

Running triple AMD 7970's all underwater.

Asus dont offer any chipset drivers for Win 10.
Is that normal?

Ive got it all up and running cleanly, no problems, but I have no crossfire options in the AMD software.
Ive unplugged one card to try and help diagnosis as triple cards can be hard work, wheere as 2 are normally easy.
I have now noticed one card is at 16x and the other 2x on the PCIE bus.

The software still wont offer me crossfire support.
I have a feeling this is chipset driver related... But there are none to change!

can anyone help at all?



++ LucidHydra NF200 Chip was probably what allowed 3 way to work, lucid no longer exist and there is no driver for win 10, you could try installing the lucid software in Win 7 compatibility mode. but im not sure of whether you will be successful.

79676
79677

Stu
Level 10
Thanks, apologoies for the late reply, I thin you are right, i eventually gave up and upgraded the lot.

Maximum X / 8700K and a 2080.
That solved the problem... LOL

Asus Maximus IV Extreme Z
i7 3770K @ 4.4ghz
AMD 7970 HD x3 in TriFire @ 1200/1800.
2x 240GHZ OCZ Vertex 3 SSD & 1x 512Gb Vertex 4
16GB 2133mhz Patriot DDR3
Ennermax Max Revo 1500w PSU
Huge water loop with an internal EK 340mm & external Supernova 1260mm
Windows 7 64 bit.

Aquaero Fan control & monitoring