cancel
Showing results for 
Search instead for 
Did you mean: 

M7R Problems, is the Maximus VII Ranger worth it? Or should I return it?

Nahrga
Level 10
Hello there ROG Forum.

I bought the Maximus VII Ranger motherboard for about 2 days ago, and so far it is working fine I guess. However, after browsing the forum I found that this motherboard has some annoying issues that Asus doesn't want to fix. One of them is the audio popping issue which I got as well: https://rog.asus.com/forum/showthread.php?54761-Audio-Popping
The other is the ACPI errors in Event Viewer: https://rog.asus.com/forum/showthread.php?48808-Help-Multiple-ACPI-Errors

This motherboard is my second ROG product, as my first was the G55VW laptop which gave me more trouble than it was worth. This left me with a bad taste, and now that taste is on its way back with this motherboard. I got both of the issues, so here are my questions:

A: Is the audio popping issue going to be present in games as well? And can it be fixed with a PCI-E sound card?

B: Are the ACPI errors in Event Viewer going to give me issues? Are they harmful? Or just errors that can be ignored?

C: I get a critical Kernel-Power error id 41 in Event Viewer every time I turn off or restart my PC. The PC is acting normal though. Is that error normal?

Please tell me if there is more known issues with this board than I found/listed.
Thanks in advance 🙂

EDIT: I decided to keep the motherboard. The audio popping issue only occur on a few of the headphones I've tried, so I guess I can live with it. I tried an USB soundcard where there was no audio popping, so I could just switch to another sound card in the future if I must.
The ACPI errors I'll just ignore. However, I don't know about the critical Kernel-Power error id 41, other than I disabled fast boot in Windows and on motherboard and the problem disapeared. I guess I'll just leave like that.
I also found out about the frozen BIOS clock issue that many Z87 users are struggling with. The same issue can be found on some Z97 boards as well. I just hope that this won't be an issue for me or that I get some other wierd issues.
3,795 Views
4 REPLIES 4

Norcus
Level 8
Nahrga wrote:
...

A: Is the audio popping issue going to be present in games as well? And can it be fixed with a PCI-E sound card?

B: Are the ACPI errors in Event Viewer going to give me issues? Are they harmful? Or just errors that can be ignored?

C: I get a critical Kernel-Power error id 41 in Event Viewer every time I turn off or restart my PC. The PC is acting normal though. Is that error normal?

Please tell me if there is more known issues with this board than I found/listed.
Thanks in advance 🙂

A: Don't know, Don't know (I have a Gene and never had sound issues. I suspect this is largely a software problem)
B: No, No, Yes
C: Yes its normal, but it is a symptom of a problem. Does it occur when you shut down using the Shut Down option in the Start Menu?

Norcus wrote:
A: Don't know, Don't know (I have a Gene and never had sound issues. I suspect this is largely a software problem)
B: No, No, Yes
C: Yes its normal, but it is a symptom of a problem. Does it occur when you shut down using the Shut Down option in the Start Menu?


Thank you for answering my questions 🙂
Yes, the critical kernel-power error happens when I use the shut down option in start menu. Fastboot fails because of it, so startup is a bit longer. I've just reinstalled windows on another HDD instead of my SSD, that did however not fix my issue.

The motherboard is running BIOS version 2101. Could it be BIOS?

EDIT: It is the exact same issue as in this thread: https://rog.asus.com/forum/showthread.php?58666-Asus-maximus-VII-Z97-Win-8-1-Fastboot-error(Logbook)

EDIT2: More people with the same issue: https://rog.asus.com/forum/showthread.php?50431-Kernel-Power-Error-Event-ID-41-Task-63 ... Sigh.. 😕

LordMas
Level 7
For what its worth i have been using my Ranger all week turning it on and off to install various hard drives, messing around with fans and cable tidying.

I have just searched my event logs for ID - 41 and the ones listed in your last link, i havent found any events in my event log. Perhaps you got a dodgy board? I would replace it under the warranty if so just to be sure.

My BIOS Version is 0904. Generally i dont do BIOS updates unless it will fix an issue i am having.

LordMas wrote:
For what its worth i have been using my Ranger all week turning it on and off to install various hard drives, messing around with fans and cable tidying.

I have just searched my event logs for ID - 41 and the ones listed in your last link, i havent found any events in my event log. Perhaps you got a dodgy board? I would replace it under the warranty if so just to be sure.

My BIOS Version is 0904. Generally i dont do BIOS updates unless it will fix an issue i am having.


I found a person with the same problem on a Z87 motherboard. He found that it was caused by a smartcard reader: https://rog.asus.com/forum/showthread.php?47037-Fastboot-problem-Windows-8-1-Pro-Update1-w-MediaCent...
So I guess my problem could be one of my USB devices? I'll test it out tomorrow, and I believe my G110 could be the culprit.

Out of pure curiosity, what is your specs LordMas? and what keyboard and mouse do you use? 🙂