Showing results for 
Search instead for 
Did you mean: 

M6H/Ethernet Controller/Windows 8.1/UEFI

Level 11
Hi all,

Has someone tried updating the M6H (and possibly M6E) Intel Ethernet Connection I217-V?

The board driver (installed with W8.1) is provided and signed by Microsoft with version, dated 03/28/2013.

The current version on Intel download center is 18.3, dated 5/15/2013.

I’ve tried updating many times, with diferent CSM bios settings, and with Intel installer the result was every time “This packet is not supported on this platform or OS”.

Odly, the M6H mobo installation disk says there is not any LAN driver installed, and if i try to install the disk driver ( it can’t do this and the driver remains the Microsoft

More odly yet, if i try update with M6H ASUS support website driver (v., the installer says ‘’It’s not possible to install drivers. There are not any Intel Network Adapters in this Computer”!!:confused:

So, i was not able to update the Intel Ethernet driver whatever way i tried, and i’d like to know if someone succed in this and how or any clarification on subject.

Thanks very much.

Level 15
Reboot your laptop and spam hit F8, get into Safe Mode and when you're in, uninstall the Microsoft Drivers and then try to install the Intel ones, either from ASUS' support site, or from your driver disk and see how that goes for you 🙂

Level 11
Hi Myk,

Thanks for your answer, but i have tried that and when i uninstall the driver, the network adapter is also uninstalled (!!) and it's like there is not a hardware adapter installed and so the disk installer can't install drivers.

With Intel installer, the result was the same “This packet is not supported on this platform or OS”.

I'm thinking that with Windows 8 the mobos M6H, M6G, M6E and probably M6F's Ethernet adapter Intel I217-V cannot be updated like we were used to do in the old generation mobos, but only with special software related with UEFI bios or OS.:confused:

More and more limitations...

Level 11
No one have tried to update ethernet controllers' driver on UEFI VI mobos? i can't believe that 🙂

Level 8
I have and all good. From this url

Make sure you are choosing the right "bitness". Me 64 bits. Your error sounds alot like 32 driver on a 64bit machine. My version is somewhat different from what you have written however.

I have

Intel : 26/02/2013 :

for driver version and if I click on the Link Speed tab I have

Intel(R) PROSet version

So definitely not an MS driver but one revision less than what you have stated :

My system hung when trying to install drivers off the disk that came with the mobo so I went directly to Intel site.

Level 11
rismROG thanks for the reply.

i was so intrigued with this that i uninstalled W8.1 and reverted to the trusted and familiar W7, and all was OK.

I did a little reserch about the subject and what i was able to understand is that it seems W8.1 (and probably W8) have compatibility issues with some Intel network adapters, more specifically with the PROSet software component of these adapters.

W8.1 pack comes with the network adapter driver soft, which is the revision of Intel (which comes with Intel 18.3), and it's impossible to change this driver with usual means.

The's driver provider is Microsoft, differently from which provider is Intel!!!

Differently, W7 pack comes without any driver soft for Intel Ethernet Connection I217-V, and we must install the driver from mobo disk or via a USB or other mean pre-loaded with it.

This is what i suppose is happening and i'd like to know if someone could confirm that.

BTW rismROG, i suppose youre on W7, or other OS that not W8.1, can you confirm that?

thanks and regards

Level 8
Hi squawker,

Nice info. That makes sense since 8.1 is still BETA right?

Sounds like the cadence of Microsofts release program has gotten ahead of hardware vendors ability to supply tested drivers hence why the driver is signed by Microsoft and not Intel as per that driver I get from the Url I posted above. i.e. made by Microsoft, not Intel.

I thought 8.1 was a just a UI modification but looks like things have gone much deeper than that if it's introducing NIC driver incompatibilities and an "assumed" need to rewrite other vendors drivers.

Me - Im on 64bit Windows 8.0 Pro. So no not 7.

Guess I'll be on 8.0 for a while now till 8.1 is sorted.
Im over being bleeding edge - too much hassle. I just want to compute and be merry. 😛